Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
SuSE Installation runs monitor Out of Range
  • From: "Terje J. Hanssen" <nteknikk@xxxxxxxx>
  • Date: Sun, 23 May 2004 14:29:06 +0200
  • Message-id: <40B09912.2030705@xxxxxxxx>
This is not a new problem for the 9.1 Installation; it has existed since I first tried SuSE 8.1 evalution, and I reported it also for 9.0. Maybe it can be figured to be a X problem, but it is so stupid that Suse seriously should solve it and avoid it! From time to time I see correspondingly problems reported, and new users facing this can leave Suse Linux before they really are able to begin.

Currently I have a x86 Athlon PC with a ATI Rage 128 graphic card and a good 19" LCD monitor, Viewsonic VP191b, which manages 1280x1024 at maximum 75Hz and 24 bit color depth. (But I have experienced correspondingly problems with other hardware too).

Here is what happends:

On the blue bootscreen after starting the SuSE Installation from CD1 or DVD1, I seehave verified that the "F2 menue" is utomatically set to 1280x1024 resolution. From bad experiences, I know that this immediately and temporary has to be manually "stepped down" to 1024x768 using the F2 key. (It looks like 1280x1024 is preset with 85Hz refresh rate/vertical frequence, which my monitor cannot manage).

I made a fresh New 9.1 Pro full installation and lowered first the resolution to 1024x768 with F2. But after the software installation, I unhappily didn't discover or test the monitor setting, which during the the system configuration had been recognized as and set to VESA 1280x1024@85. The result: after a full 9.1 installation the system rebooted, but then run my monitor "Out of Range" in message box on a black screen.

And I was not able to come out of this problem (tried to "Repair" and "Failsafe" without succeed), and had to do a time consuming quite New installation. But this time, after the software installation, I changed the automatic monitor setting from VESA 1280x1024@85 to LCD 1280x1024@75, which then worked well with my monitor.

This problem is too stupid and cumbersome to be true. If one is able to do grahical login, it is possible to change the graphic/monitor configuration with SaX2. But if one forget at the same time to test the configuration, I think the same problem can arise also from here.

The question is; if one cannot do a graphical login because of running "Monitor out of Range", what to do then? Is it possible to "rapair" the configuration settings or select a command line login? If so, possibly how and where to change/edit the graphical configuration (resolution, frequence and color depth)?

(To compare with CDE/Solaris, it is easy to break the CDE startup, just by entering the return key before CDE login screen starts. Then the command line login is made available).


Regards
Terje J. Hanssen

< Previous Next >