Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
Re: Re: [SLE] I'm going to have to return SuSE tonight
  • From: <me@xxxxxxxxxxxxxxxxxxx>
  • Date: Thu, 20 May 2004 18:33:28 -0700
  • Message-id: <3336B131482F49B19FD72F4863F98C43.MAI@xxxxxxxxxxxxxxxxxxxxxxxxxxxx>
----- Original Message -----
From: Sid Boyce
To: suse-linux-e@xxxxxxxx
Sent: Fri, 21 May 2004 01:01:36 +0100
Subject: Re: [SLE] I'm going to have to return SuSE tonight

me@xxxxxxxxxxxxxxxxxxx wrote:

>I don't know why I'm having this problem, but I know I didn't have it with Fedora. Basically I
>installed a couple days ago. Upon reboot one time I got an error stating something to the effect
>that libc.so.6 was unable to receive messages of type LHS or something like that. I added a second
>hard drive (to separate data from the OS) in case this happened again and I reinstalled. Well, it
>happened again this morning, just a couple days later. No idea why. But when it happens I can't
>recover the system. I can't update the system. All I can do is reinstall. Anything that uses Glibc
>(pretty much everything) quits functioning and gives this error.
>
>Anyone else seen this? I can't imagine that this would be a hardware problem. I did a memory test
>the first time and all the memory checked out. I'm running on a new hard drive now (with the old
>one being a data drive like I said earlier). So I can't imagine that would be the problem. But for
>whatever reason the files for libc get hosed so the OS just quits working.
>
>Preston
>
>
>
>
Sounds like a data corruption problem. I've only seen this type of
problem when I used kernel.org 2.6.x-mm kernels with the
make-4k-stacks-permanent.patch installed and using the nvidia video
driver, but your situation suggests a regulation install with a SuSE kernel.
Some hardware details would be of interest, the filesystem type you are
using, Fedora uses ext3, I don't know if you stuck with that, if so I
would suggest you try reiserfs instead.
I normally use a boot CD (knoppix or timos rescuecd) to run reiserfsck
(when I did that, it confirmed that my reiserfs was trashed). It may be
possible with the SuSE boot CD/DVD to do a filesystem check.
Regards
Sid.

--------------------------------------------------------

Sorry for the bad formatting. My web email program.

Anyway, I've tried all the above rescue options, as I mentioned. I tried doing an update, an actual
rescue where I ran a filesystem check and everything came out okay. What didn't come out okay was
this libc problem.

I also thought about the possibility that it was a bad filesystem driver or a bad hard drive. That
was the reason for the hard drive purchase. But obviously I've tried that and I've also tried
different filesystems. My Fedora install was running reiserfs, actually. Because I've always
preferred that filesystem (it's hidden in Fedora's install, but if you type "linux reiserfs" at the
boot for the install disk you can install onto reiser). So I went out of my way to run Fedora on
reiserfs and it ran fine. Did the same with SuSE and it had this problem. Next time around
(thinking it might be a problem with the reiserfs implementation) I tried ext3. Same result last
night. So no good there. That didn't really help any.

So now I'm completely lost. A computer that functioned perfectly fine now goes completely haywire
every couple days no matter what hard drive or filesystem I use. I really have no choice but to
consider that the problem lies with the OS itself. I respect the fact that others are having no
problems, but I'm having plent. And I've run everything from SuSE 8.0 to SuSE 8.2 to FreeBSD to
Mandrake to Fedora on this machine without any problems. And the Fedora install was a 6 month
install that I yanked less than a week ago in exchange for SuSE. So that's really the only thing
that's changed unless this is somehow indicative of a motherboard going bad or an IDE chain gone
bad (I've already checked the RAM). Otherwise, I have to believe it's something with the OS. And it
always works at the start. It goes bad after a few updates online.

Preston

< Previous Next >
Follow Ups