Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
Re: [SLE] Re: USB scanners in 9.1
  • From: Sid Boyce <sboyce@xxxxxxxxxxxxxxxx>
  • Date: Thu, 20 May 2004 20:29:35 +0100
  • Message-id: <40AD071F.2040602@xxxxxxxxxxxxxxxx>
Fergus Wilde wrote:

On Tuesday 18 May 2004 23:11, Sid Boyce wrote:

John Pettigrew wrote:

In a previous message, Fergus Wilde <fwilde@xxxxxxxxxxxxxxx> wrote:

this time it's the scanner, which has been set up nicely for several
versions. Installs OK, but then xsane says 'no device'.

Probably no help, but my USB Canon LiDE 30 worked with no problems in 9.1
- just set up using YaST, then run xsane or kooka and it worked.

John

I don't know what is supported in the SuSE kernel, but usb scanners were
taken out of the 2.6.x tree. One posting to the kernel mailing list
suggested the guy tried libusb and if it didn't work, pass it on to the
libusb and sane maintainers. I tried the latest cvs of libusb and that
failed to recognise my Epson 610 scanner. I checked google and found
vuesca76.tgz, the free version, works a treat. I just checked
http://www.hamrick.com/ and there is vuesca80.tgz, mkdir
/usr/local/vuescan and exploded it there, ln -s
/usr/local/vuescan/vuescan /usr/local/bin/, fired it up and it worked
first time.
Regards
Sid.


Thanks then Sid, vuescan does indeed work, and looks rather good. I've not properly explored it nor its licensing yet. Seems there's a commercial version as well. It finds and opens the image in Gimp 2.0, which is great - but do you happen to know a dodge for preventing it starting a new instance of gimp each time you scan?

I think the license is something like $59.00 US, you get updates and support for that.
I can't find any options to stop gimp opening multiple instances.

I'd like to understand why xsane doesn't, I must say ... the scanner is an Epson Perfection 2450 photo that works beautifully under 8.2 and 9.0. Scanimage reports it as a GT9700, which is wrong, but it does the same under 8.2 and that doesn't stop it working properly.

Thanks too to Patrick, who suggested looking at /etc/sane.d/epson.conf - it certainly looked different to /etc/sane.d/epson.conf under 8.2, and the only uncommented lines read (9.1):

usb
usb 0x4b8 0x112
usb 0x4b8 0x112
usb 0x4b8 0x112
usb 0x4b8 0x112

Under 8.2, the only uncommented line in the same file read

usb /dev/usbscanner.

For completeness, I tried substituting that line for the setup 9.1 had created, but you may not be surprised to hear it didn't work.

So does anyone have an Epson USB scanner working nicely just as expected under 9.1? If so, please post any config files for it.


My problems were all on 9.0, where epson.conf contained /dev/usbscanner. The 9.1 upgrade seems to have removed the sane packages.
Regards
Sid.

--
Sid Boyce .... Hamradio G3VBV and keen Flyer
Linux Only Shop.


< Previous Next >