Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
Re: [SLE] AIT drivers and 9.1
  • From: Fortean <tr011@xxxxxxxx>
  • Date: Tue, 18 May 2004 07:22:14 +0100
  • Message-id: <200405180722.14309.tr011@xxxxxxxx>
I own a Radeon 9800 myself and I couldn't get the fglrx drivers to compile
with the out-of-the-box kernel. Update the kernel to the current one
(2.6.4-54.5) and re-install the drivers. Be certain to have done make
cloneconfig as well, I think you perhaps passed over that step.

Also, take notice that in the Suse instructions there is no mention of running
fglrxconfig. I was unable to get dga to work using fglrxconfig and I had some
strange artifacts at the desktop.

011

On Tuesday 18 May 2004 05:44, Adolph & Sharon Weidanz wrote:
> I've posted this in the suse-xfree86 group and didn't get an answer so
> I'll try here. First if all your going to say is get an nvidia card,
> don't bother posting. I have a laptop and do not have a choice.
>
> I am trying to get the ATI drivers that SUSE has posted in the 9.1 dir.
> Along with the readme. I followed the directions, although I am using
> the 2.6.5-17.0-defalut kernel, and yes I am sure my link is set to the
> correct source and they match.
> First I tried to use the current ati (3.7.6 ?) drivers from the ati site
> and ran the fglrxconfig. All this gave me was 2d and the mesa drives
> (Did find out an interesting thing though, fglrxconfig creates a
> XF86Config-4 file that is linked in somewhere and the config file
> created by sax2/yast is ignored), anyway I then followed the SUSE
> directions.
> ftp.suse.com/pub/suse/i386/supplementary/X/XFree86/ATI/suse91/fglrx/
>
> I got to the part where it says to cd to /usr/src/kernel-modules//fglrx/
> and the KERNEL_SOURCE=/usr/src/linux make modules. I do not get any
> further. It dies first with warning that Module.symvers is missing and
> modules will have CONFIG_MODVERSIONS disabled. then it:
>
> building modules stage 2
> MODPOST
> binj/sh: line 1:scripts/modpost: no such file or directory
> make[2]: ***[__modpost] error 127
> make[1]: ***[modules] error 2
> //Then it quits
>
> I checked and there is a dir scripts, but no modpost (Has modpost.c &
> modpost.h and a makefile, more on this later) There is a dir 2.6.x that
> when i first entered had just a makefile, so I ran make and it copied
> all the files fromn the above dir and created the .o's &.o.cmd's files.
> It doesn't have a make install though, also KERNEL_SOURCE=/usr/src/linux
> make modules doesn't do anything.
>
>
> --
> Adolph & Sharon Weidanz
> '78 43' Endeavour Ketch
> S/V Time To Paws

< Previous Next >