Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
Re: [SLE] AIT drivers and 9.1
  • From: Curtis Rey <crey@xxxxxxxxxx>
  • Date: Mon, 17 May 2004 20:14:10 -0700
  • Message-id: <200405172014.14967.crey@xxxxxxxxxx>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On Monday 17 May 2004 09:44 pm, Adolph & Sharon Weidanz wrote:
> I've posted this in the suse-xfree86 group and didn't get an answer so
> I'll try here. First if all your going to say is get an nvidia card,
> don't bother posting. I have a laptop and do not have a choice.
>
> I am trying to get the ATI drivers that SUSE has posted in the 9.1 dir.
> Along with the readme. I followed the directions, although I am using
> the 2.6.5-17.0-defalut kernel, and yes I am sure my link is set to the
> correct source and they match.
> First I tried to use the current ati (3.7.6 ?) drivers from the ati site
> and ran the fglrxconfig. All this gave me was 2d and the mesa drives
> (Did find out an interesting thing though, fglrxconfig creates a
> XF86Config-4 file that is linked in somewhere and the config file
> created by sax2/yast is ignored), anyway I then followed the SUSE
> directions.
> ftp.suse.com/pub/suse/i386/supplementary/X/XFree86/ATI/suse91/fglrx/
>
> I got to the part where it says to cd to /usr/src/kernel-modules//fglrx/
> and the KERNEL_SOURCE=/usr/src/linux make modules. I do not get any
> further. It dies first with warning that Module.symvers is missing and
> modules will have CONFIG_MODVERSIONS disabled. then it:
>
> building modules stage 2
> MODPOST
> binj/sh: line 1:scripts/modpost: no such file or directory
> make[2]: ***[__modpost] error 127
> make[1]: ***[modules] error 2
> //Then it quits
>
> I checked and there is a dir scripts, but no modpost (Has modpost.c &
> modpost.h and a makefile, more on this later) There is a dir 2.6.x that
> when i first entered had just a makefile, so I ran make and it copied
> all the files fromn the above dir and created the .o's &.o.cmd's files.
> It doesn't have a make install though, also KERNEL_SOURCE=/usr/src/linux
> make modules doesn't do anything.
>
>
> --
> Adolph & Sharon Weidanz
> '78 43' Endeavour Ketch
> S/V Time To Paws

HI there, I have gotten the fglrx drivers working in 9.1. They are a little
flakey in Tribes2 but otherwise fine. Your first error was to run the
fglrxconfig. You should have run the following:

#sax2 -r -m 0=fglrx -b /usr/X11R6/lib/sax/profile/firegl.

Then I do:

#pico /etc/X11/XF86Config and add the line

#Load "dri"

Furthermore, you might want to install the "km_dri" module via YaST.

Also, the ATI drivers from ATI's site generally (last time I tried) make a
install dir in /usr/lib/modules, Unlike the ones from the SuSE site (if this
has changed since I tried this in 8.2 then disregard).

You may have to manually remove the files. But I had fits trying to deal the
the rearrangement the the fglrxconfig did in my X system by pointing
everything to the XF86Config-4 file (it's essentially outdated and mostly
unused AFAICT by other distros).

You might try removing X and then reinstalling it, or do a overwrite with the
rpm files with the "--replacepkgs" and "--replacefiles" flags. (e.g. rpm
- -Uhv Xwhatever.rpm --replacepkgs --replacefiles). And please post the out
put from you "X.errors" files and your "XFree86.0.0.log" (may not need to
post the whole log file - just the parts related to X message entries).

HTH, Curtis.

- --
Spammers Beware: Tresspassers will be shot,
survivors will be shot again!

Warning: Individuals throwing objects at
the crocodiles will be asked to retrieve
them!

If pro is the opposite of con, then the
opposite of progress must be congress!
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFAqX+F7CQBg4DqqCwRAh7WAKC23dGrxhtsrkPqkMV/R1z6o4VhOACfVKOS
+0TPj5U2doaKlNeBeNijmlw=
=CnZk
-----END PGP SIGNATURE-----

< Previous Next >