Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
Re: [SLE] Silicon Image sil3112a: is this CRAP?
  • From: Hans du Plooy <hansdp@xxxxxxxxxxxxxxxxx>
  • Date: Mon, 17 May 2004 09:17:53 +0200
  • Message-id: <1084778273.12180.10.camel@xxxxxxxxxxxxxxxxxxxxxxxxx>
On Fri, 2004-05-14 at 19:18, SuSE Ground Zero wrote:
> I am tring to load sata_sil.ko. It loads perfectly but in dmesg doesn't show
> some new scsi devices. I got just the message "libata version 1.02
> loaded." and thats all.
> Do I have to recompile the kernel with config_broken or something else?
>
> Linux kcore 2.6.4-54.5-smp #1 SMP Fri May 7 21:30:47 UTC 2004 i686 i686 i386
> GNU/Linux
>
> SuSE 9.1 the latest stock kernel from online update.

I'm posting this back to the list because I don't have any SATA drives
in my machine to noodle around with, and all the SATA raid machines I've
worked with worked out of the box, so I don't have any experience
troubleshooting them.

But let's give it a shot. Is this raid setup on the card itself, or in
hardware? The last machine I did had 3 discs striped on the card
itself. SUSE 9.0 and 9.1 both saw one big disc - /dev/sda

Maybe there are parameters you have to specify. Have a look in the
kernel source directory - there maybe something in the module source -
commented information on what options you could specify with it.

Also, have you tried using the "disc controllers" module in yast2?

--
Kind regards
Hans du Plooy
Newington Consulting Services
hansdp at newingtoncs dot co dot za


< Previous Next >