Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
Re: [SLE] SuSE 7.1 Recovery
  • From: David Johanson <dcjohan@xxxxxxxxxxx>
  • Date: Sat, 15 May 2004 17:12:31 -0400
  • Message-id: <40A687BF.6000902@xxxxxxxxxxx>


Jerome R. Westrick wrote:
On Sat, 2004-05-15 at 01:43, David Johanson wrote:

For reasons related to work, I use one box that used to (and still needs to ) dual boot with win98se. A few days ago the 98 side went totally south, and cannot even be fiddled with in safe mode. Thus I need to reload 98 which will over write the LILO boot loader. No problem except that I can't find any way to actually reload LILO.


What I do is to boot from CD (or DVD) and select boot installed system.
THen you choose your root partition, and Linux starts...
Once you got Linux up and running, you can reinstall LILO with the
standard commands...

Hope this helps
Jerry


This "how to recover my 7.1 system" has been bothering me for quite some time. Your suggestion of trying to re-load from another CD was something that had crossed my mind earlier but for some reason I just never bothered to try it. Not sure what had caused that mental block because with an earlier install of 8.1 that I was playing around with I actually did just what you suggested but somehow never considered using anything other than the 7.1 CDs. DUH!

Yesterday when playing around with the 7.1 installation I tried making a boot CD from YaST -- YaST2 | control Center | Misc | configure Bot-Mode and selected "Create a boot floppy." After so doing I tried booting with the newly created floppy in the "A" drive but didn't notice any drive "A" activity and the system booted as usual. This, erroneously, led me to believe that the disk was a failure and I just set it aside. Today when I booted into the system it failed to boot giving me screen full after screen full of . . . . . following the line looking for a boot image. I tried booting several times always getting the same results. I was getting rather frustrated when I decided to put in the boot disk made yesterday, just because I could think of nothing else to do. Again there was minimal boot activity, almost none save for a couple of early on blinks of the drive "A" light, and this very early in the start phase, almost at BIOS start time, but the system booted as usual. I then tried without the disk in the drive and once again the series of . . . I then put the disk back in the drive and everything worked as desired. This time I went back into YaST and opted for a write to the boot disk MBR and let that run. Viola, system again booted from the hard drive. So I now realize that not only did I create a functional boot floppy, but that by doing so with YaST I altered the system. Learned something new today.

Next I tried booting from the 9.1 Disk #1 and found that, of course, that works also, although it failed to find and setup the eth0 connection. But who cares, once booted, sbin/lilo should be able to take care of that.

Thanks for your suggestion; made put think a little which proved fruitful!

dave

--
David C. Johanson
Linux Counter # 116410
Powered by SuSE Linux 7.1

People who behold a phenomenon will often extend their thinking beyond
it; people who merely hear about the phenomenon will not be moved to
think at all. -- Goethe


< Previous Next >
Follow Ups