Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
Forcing 100Mb/s Full Duplex in 9.1
Hi,

I've several machines that were running Suse 9.0 with Intel network
cards which use the E100 module.

Normally I add 'options e100 e100_speed_duplex=4' to
'/etc/modules.conf' to force the card to 100Mb/s Full Duplex.

I upgraded my 9.0 machines to the beta version of the 2.6 Kernel and
moved the above line to '/etc/modprobe.conf' as the above file is no
longer used which still worked.


However after upgrading the machines to Suse 9.1 I no longer have this
option, typing 'lsmod e100' reveals no available options for setting the
speed and duplex.

This is frustrating as I run an online games service where low latency
is critical, my Cisco switches are set to 100Mb/s Full Duplex but if I
leave the cards on auto they always set themselves to Half Duplex and
everything runs like a dog.

mii-tool doesn't work with the e100 module so I can't use that.


Does anyone know of a work around or should I drop back to 9.0 and the
beta which worked without problems, however the CPU load is lower on 9.1
so I'd rather keep this if possible?

Can you use a 2.6 beta module with 9.1?


Thanks in advance.


Matthew





< Previous Next >
Follow Ups
References