Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
Re: [SLE] 9.1 USB Mouse Problems
  • From: Sid Boyce <sboyce@xxxxxxxxxxxxxxxx>
  • Date: Wed, 12 May 2004 20:38:35 +0100
  • Message-id: <40A27D3B.80106@xxxxxxxxxxxxxxxx>
Bill Bradley wrote:

Hello All,
mo
I just installed 9.1 on my notebook and am loving it. However I am
having a major usb problem in that it is not working at all. After the
install I used online update to grab patches and updated the kernel to
2.6.4-54.5. I have tried to get my usb mouse and flash drive working to
no avail. Here is the output of lsmod|grep usb:

usbserial 28912 0
usbcore 96988 3 usbserial,hid

So i though ok, no mouse so I did a modprobe usbmouse and got:

FATAL: Module usbmouse not found.

Does it seem weird that suse wouldn't include modules in a kernel
update. Is there a package or way around this with out recompiling.

thanks,
bill bradley



I don't know if this relevant or if the SuSE kernel has changed from the standard "usbhid" module.
usblp 13888 0
hci_usb 15424 0
bluetooth 53572 6 l2cap,hci_vhci,hci_uart,hci_usb
usbhid 34368 0
usbserial 33528 3 pl2303
usbcore 127792 9 usblp,hci_usb,usbhid,pl2303,usbserial,ehci_hcd,uhci_hcd

I'm using 2.6.6-mm1 from kernel.org and I changed modprobe.conf from "hid" to "usbhid" and my mouse worked instantly, serial port (pl2303) I have yet to figure that out in modprobe.conf, but "modprobe pl2303" got it working.
Regards
Sid.

--
Sid Boyce .... Hamradio G3VBV and keen Flyer
Linux Only Shop.


< Previous Next >
This Thread
References