Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
Re: [SLE] Win4Lin 4.0 and SuSE Linux 9.1
  • From: Chip Cooper <ccooper3@xxxxxxxxxxxxxxx>
  • Date: Wed, 12 May 2004 14:32:59 -0400
  • Message-id: <40A26DDB.3070100@xxxxxxxxxxxxxxx>
Prabu Subroto wrote:

Ooo...Oooo............. I installed this :
"
Kernel-Win4Lin3-NeTraverse1.0_2.4.25-02.i686.rpm
Single CPU, i686 or newer (Pentium Pro/2/3/4, AMD
Athlon, etc.)
"
But once I started win4lin-install again, I still got
the same error message. Pheww.....

One guy in another mail-list told me that I must
upgrade my win4lin to get my win4lin on 2.6 kernel
works.

Please tell me your opinion whether the advice
correct. I just want to make sure before I waste my
money more.

TIC
===
To:
"Win4Lin Users List" <win4lin-users@xxxxxxxxxxxxxx>
Date:
Wed, 12 May 2004 07:47:55 -0400
From:
"Leonardo E. Reiter" <lreiter@xxxxxxxxxxxxxx> Add to
Address Book
Subject:
[Win4Lin-users]Re: Win4Lin 4.0 and SuSE Linux 9.1

Win4Lin 4.0 does not work on 2.6 kernels. Please
contact sales@xxxxxxxxxxxxxx to inquire about an upgrade to
5.1.

Best regards,

Leo Reiter
--- Chip Cooper <ccooper3@xxxxxxxxxxxxxxx> wrote:

Prabu Subroto wrote:


Dear my friends...

I am using Win4Lin version 4.0 on SuSE Linux 9.1 .

I

just upgraded my SuSE from 8.2 to 9.1 . When I used
SuSE 8.2 this Win4Lin worked properly but since I
upgraded my SuSE 8.2 to SuSE 9.1 my Win4Lin doesn't
work anymore. I get an error message as if the

kernel

of Win4Lin has not been loaded.

I tried to re-install my Win4Lin. I removed it and
then install it again with "win4lin-install". But

this

time my "win4lin-install" does not run as I

expected

(as usual).
I was surprised because of this error message :
"
LINUX SYSTEM ANALYSIS
Your system is not supported for automatic

updating.

Either you are running a system which is no longer
directly supported, or you are running a

hand-patched

kernel and neet to repatch with the latest

Netraverse

patches.
"
Please tell me what I should do. I need the Win4Lin
because I still need to work with RouterSim, and it
runs only on Windows platform. I will do CISCO
certification test in a short time. I need my

win4lin

urgently. Pleasee............

Thank you very much.



The problem is that when you upgraded to the new
kernel (9.1), it is not supported by win4lin. I have the same problem. I
recently did the suse online update which upgraded my kernel. After reboot
win4lin no longer works. I have been in communication with win4lin
tech support. This was there reply:

Hello,

Once you install a new kernel with YAST, you will no
longer have kernel support for Win4Lin. Then when you try to
update Win4Lin it will not recognize your new SuSE kernel as supported.
This is because New Win4Lin kernels are distribution independent. We no
longer build kernel for each individual distribution's kernel.
For a copy of Netraverse's kernel policy, please refer to http://www.netraverse.com/kernel_policy.php.
The problem you ran in to is not that we don't have
the support for your distribution, its that the installer does not
yet handle the new kernels. It will in the future, but until it does
you have to download and install the kernel manually.
To download the latest 2.4.x or 2.6 kernels, please
refer to

http://www.netraverse.com/member/downloads/kernel_generic.php.

Once you download the kernel for your system,
install it using the "rpm -i" command. Reboot your system, and run
win4lin-install to finish the installation.
If you prefer, you can download the generic 2.6.6
kernel from kernel.org and apply the netraverse patches manually
to create a custom kernel. These can be found at

http://www.netraverse.com/member/downloads/kernel_patch.php

Anyway, I tried that and it didn't work--so i am
stuck too. If I get it fig. out I will let you know.

Chip




__________________________________
Do you Yahoo!?
Yahoo! Movies - Buy advance tickets for 'Shrek 2'

http://movies.yahoo.com/showtimes/movie?mid=1808405861





--
Check the headers for your unsubscription address
For additional commands send e-mail to
suse-linux-e-help@xxxxxxxx
Also check the archives at http://lists.suse.com
Please read the FAQs: suse-linux-e-faq@xxxxxxxx








__________________________________
Do you Yahoo!?
Yahoo! Movies - Buy advance tickets for 'Shrek 2'
http://movies.yahoo.com/showtimes/movie?mid=1808405861

No, the problem is that win4lin kernerls are not compatible with the/ suse upgraded kernel/. They use to be. I have done this before and whenever I upgraded my kernel, I would simply delete my win4lin and kernel-win4lin and re-run the win4lin installer, which would install the win4lin kernel that was appropriate. Well, that is not working anymore and their tech support has not been very helpful (they use to be more helpful in the past).
I have win4lin also installed on my laptop with suse9.0 and it works fine. However, when I installed suse9.0, I didn't get any online updates, but installed /as is/ from the disks. Suse Kernel updates screws everything up.
However, I think your prob is different. When I upgraded to 9.0 I had to wait about a month before netraverse got the kernel built that worked with 9.0. Might be a similar situation since 9.1 was just released. Send their tech ppl an email and ask when they will have support for suse 9.1.

Chip

< Previous Next >
References