Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
Re: [SLE] Win4Lin 4.0 and SuSE Linux 9.1
  • From: Chip Cooper <ccooper3@xxxxxxxxxxxxxxx>
  • Date: Wed, 12 May 2004 07:53:04 -0400
  • Message-id: <40A21020.6030708@xxxxxxxxxxxxxxx>
Prabu Subroto wrote:

Dear my friends...

I am using Win4Lin version 4.0 on SuSE Linux 9.1 . I
just upgraded my SuSE from 8.2 to 9.1 . When I used
SuSE 8.2 this Win4Lin worked properly but since I
upgraded my SuSE 8.2 to SuSE 9.1 my Win4Lin doesn't
work anymore. I get an error message as if the kernel
of Win4Lin has not been loaded.

I tried to re-install my Win4Lin. I removed it and
then install it again with "win4lin-install". But this
time my "win4lin-install" does not run as I expected
(as usual).
I was surprised because of this error message :
"
LINUX SYSTEM ANALYSIS
Your system is not supported for automatic updating.
Either you are running a system which is no longer
directly supported, or you are running a hand-patched
kernel and neet to repatch with the latest Netraverse
patches.
"
Please tell me what I should do. I need the Win4Lin
because I still need to work with RouterSim, and it
runs only on Windows platform. I will do CISCO
certification test in a short time. I need my win4lin
urgently. Pleasee............

Thank you very much.

The problem is that when you upgraded to the new kernel (9.1), it is not supported by win4lin. I have the same problem. I recently did the suse online update which upgraded my kernel. After reboot win4lin no longer works. I have been in communication with win4lin tech support. This was there reply:

Hello,

Once you install a new kernel with YAST, you will no longer have kernel support for Win4Lin. Then when you try to update Win4Lin it will not recognize your new SuSE kernel as supported. This is because New Win4Lin kernels are distribution independent. We no longer build kernel for each individual distribution's kernel. For a copy of Netraverse's kernel policy, please refer to http://www.netraverse.com/kernel_policy.php.
The problem you ran in to is not that we don't have the support for your distribution, its that the installer does not yet handle the new kernels. It will in the future, but until it does you have to download and install the kernel manually.
To download the latest 2.4.x or 2.6 kernels, please refer to http://www.netraverse.com/member/downloads/kernel_generic.php.
Once you download the kernel for your system, install it using the "rpm -i" command. Reboot your system, and run win4lin-install to finish the installation.
If you prefer, you can download the generic 2.6.6 kernel from kernel.org and apply the netraverse patches manually to create a custom kernel. These can be found at http://www.netraverse.com/member/downloads/kernel_patch.php

Anyway, I tried that and it didn't work--so i am stuck too. If I get it fig. out I will let you know.

Chip




__________________________________
Do you Yahoo!?
Yahoo! Movies - Buy advance tickets for 'Shrek 2'
http://movies.yahoo.com/showtimes/movie?mid=1808405861



< Previous Next >
Follow Ups
References