Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
hw_random error with coldplug in 9.1
  • From: Michael Nelson <michaelnel@xxxxxxxxxxx>
  • Date: Fri, 7 May 2004 16:27:42 -0700
  • Message-id: <20040507232742.GA3881@xxxxxxxxxxxxxxxxxxx>
Looking through the boot.msg file in my new 9.1 system I find this:

coldplug scanning input: done
scanning pci: ****.***modprobe: FATAL: Error inserting hw_random (/lib/modules/2.6.4-54.3-default/kernel/drivers/char/hw_random.ko): No such device

I checked, and hw_random.ko does exist, however /dev/hwrandom did not. I
read the /usr/src/linux/Documentation/hw_random.txt and it doesn't help
much, but did say:

"/dev/hwrandom is char device major 10, minor 183."

...so I created it with mknod:

$ ls -l /dev/hwrandom
brw-r--r-- 1 root root 10, 183 2004-05-07 16:05 /dev/hwrandom

...but the same error persists during boot. And if I try modprobing it
manually I get the same error:

# modprobe -v hw_random
insmod /lib/modules/2.6.4-54.3-default/kernel/drivers/char/hw_random.ko
FATAL: Error inserting hw_random
(/lib/modules/2.6.4-54.3-default/kernel/drivers/char/hw_random.ko): No such device

Anyone else seeing this error?

Thanks
Michael

< Previous Next >
Follow Ups