Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
Proper netmask configuration?
  • From: "James D. Ivey" <jim@xxxxxxxxxxx>
  • Date: Mon, 03 May 2004 14:35:58 -0700
  • Message-id: <1083620156.23563.69.camel@xxxxxxxxxxxxxxxxxxx>
I don't believe my network is configured properly, but I've tried
everything I can think of to fix it.

"ifconfig" says the following about eth0:
inet addr:192.168.1.5 Bcast:192.168.1.255 Mask:255.255.255.255

The netmask should be 255.255.255.0.

Under YaST2, eth0 is shown to have static address setup with an address
of 192.168.1.5 and a subnet mask of 255.255.255.0. Under "routing", I
can only specify the gateway address (which is correctly specified), but
I cannot specify a correct subnet mask.

As of now, weird things are happening on my system. For example, I'm
unable to get cups to work. Other little weird network things don't
work. For example, to get samba to work, I had to override the system
network settings in the configuration file to specify the correct subnet
mask.

I've tried manually overriding with ifconfig and other CLI tools.
However, my Internet access (and all network access) stops when I do
that. It's only when I go back to YaST2 that I regain that access, but
then ifconfig reports the incorrect netmask as described above.

How do I resolve the apparent disagreement as to my subnet mask?

Many thanks for any help.

Best regards,

Jim


--
James D. Ivey <jim@xxxxxxxxxxx>
Law Offices of James D. Ivey

This e-mail address is heavily spammed and heavily filtered. It's
better to reach me through my web site: http://www.iveylaw.com


< Previous Next >
Follow Ups