Mailinglist Archive: opensuse (4547 mails)

< Previous Next >
Re: [SLE] Problem with ReiserFS
  • From: Anders Johansson <andjoh@xxxxxxxxxx>
  • Date: Mon, 3 May 2004 10:27:38 +0200
  • Message-id: <200405031027.38228.andjoh@xxxxxxxxxx>
On Monday 03 May 2004 10.17, Volker Krueger wrote:
> Hi Anders,
>
> yes, this is of course correct: It may be a bad block. However, the
> correlation between the crash, which was due to experimenting with a
> Firewire camera (it had already happened a number of times!) with the final
> crash of the home is also apparent...
>
> But whatever it may be,
> there are a number of error messages in /var/log/messaged:
>
> first *a lot* of boot-up messages, also from the previous crashes about
> missing inodes
>
> is_tree_node: node level 0 does not match to the expected on 1
> vs-5150: search_by_key: invalied format found in block 598507. Fsck?
>
> They are always the same and they are repeated quite often.
>
> after the fist number of crashes, the home was always readable again, but
> the last one finally did it...
>
> Any idea if an fscheck could do the job? Any hints for senseful parameters?

Well, the problem is that with errors like that, the partition wouldn't be
mounted, as the system will refuse to mount a partition with file system
errors. If the partition isn't mounted, then the I/O error is coming from the
root partition, not /home.

You can try reiserfsck with something like --fix-fixable or --rebuild-tree,
those may fix the partition errors, but I really doubt that that is related
to the I/O error. The only times I've seen I/O errors like that is when the
disk has in some way been physically bad

< Previous Next >
Follow Ups