Mailinglist Archive: opensuse (3217 mails)

< Previous Next >
Re: xftcache program seems to be missing?
  • From: "l. Athena W." <suse@xxxxxxxxx>
  • Date: Wed, 24 Mar 2004 02:05:13 -0800
  • Message-id: <40615D59.70105@xxxxxxxxx>
shtar:/usr/lib> ll libfont*
-rw-r--r-- 1 root root 200264 2003-12-16 05:25 libfontconfig.a
-rwxr-xr-x 1 root root 864 2003-12-16 05:25 libfontconfig.la*
lrwxrwxrwx 1 root root 22 2004-03-12 09:51 libfontconfig.so -> libfontconfig.so.1.0.4*
lrwxrwxrwx 1 root root 22 2004-03-12 09:51 libfontconfig.so.1 -> libfontconfig.so.1.0.4*
-rwxr-xr-x 1 root root 187854 2003-12-16 05:25 libfontconfig.so.1.0.4*
ishtar:/usr/lib> ll libfree*
-rw-r--r-- 1 root root 1545924 2003-09-23 09:46 libfreetype.a
-rwxr-xr-x 1 root root 728 2003-09-23 09:46 libfreetype.la*
lrwxr-xr-x 1 root root 20 2003-11-04 11:57 libfreetype.so -> libfreetype.so.6.3.3*
lrwxr-xr-x 1 root root 20 2003-11-03 23:09 libfreetype.so.6 -> libfreetype.so.6.3.3*
-rwxr-xr-x 1 root root 394821 2003-09-23 09:46 libfreetype.so.6.3.3*
ishtar:/usr/lib> nm libfreetype.so.6.3.3|grep FT_Get_PS_Font_Info
0000eb00 T FT_Get_PS_Font_Info
ishtar:/usr/lib>
-------
Weird....seems to be there....

Ok....even weirder...I just executed the same command in the same font dir and it works now.
I hate this. I used to like computers because the were reliable, predictable -- they didn't change their
behavior based on what day it is or whatever....This isn't the logical behavior I'd expect from an M5...er, x86...
whatever...

Now I just have to figure out the rest of it....it might be helpful if the manpage referenced on "fc-cache" :
SEE ALSO
fontconfig(3)
__vendorversion__ FC-CACHE(1)
"fontconfig" actually existed. Somehow it didn't get installed on my system. Looks like the font config package
went out a bit hurriedly as the forgot to replace __vendorversion__ with a real version, as well.

Is that it though? I just run that and xft should pick up the new fonts? I assume I have to reload it or
restart it?...Thanks ....for getting me through the weird library problem....I ran some general verify scripts that looked for
missing non-local related files and if it found them, try to restore them, but I got a few errors on restores -- of course the
script did't list out the package it was processing on one rpm where it ran out of input data...weird..

-linda





< Previous Next >
Follow Ups