Mailinglist Archive: opensuse (3217 mails)

< Previous Next >
Warning to Win4Lin users
  • From: "Paul W. Abrahams" <abrahams@xxxxxxx>
  • Date: Thu, 18 Mar 2004 21:38:16 -0500
  • Message-id: <200403182138.16185.abrahams@xxxxxxx>
I don't know how many Win4Lin users are on this list (for those wondering,
Win4Lin is a very elegant Windows emulator that gives you a Windows window
within Linux). But if any of you are out there, here's a cautionary tale.

This afternoon, for no obvious reason, my system started acting up, with
things suddenly not working. So I rebooted, and then found I was getting
even more errors, with a whole bunch of missing modules. Very puzzling,
since I hadn't as far as I knew changed anything whatsoever.

The cause, it turned out, was that Yast was set for automatic online updating,
which I believe is the default. SuSe just released a new version of the
kernel (199, replacing 192) and so the automatic update installed it without
my being aware of it. That messed up the Win4Lin kernel mods. The cure is
simple: don't use the automatic update feature, but instead do your updating
explicitly. If Netraverse is true to form, they'll have a new set of kernel
mods out within a week, and then you can update the kernel from 192 to 199.

Paul Abrahams


< Previous Next >
Follow Ups