Mailinglist Archive: opensuse (3217 mails)

< Previous Next >
Re: [SLE] Fetchmail Problem
  • From: Arvid Johansson <arvid.johansson@xxxxxxxxxxxx>
  • Date: Thu, 18 Mar 2004 13:42:01 +0100
  • Message-id: <200403181342.01766.arvid.johansson@xxxxxxxxxxxx>
As of a couple of days ago I've been having the same problem. At first I
didn't get any mails at all with kmail so I then resorted to using fetchmail
I got the same problem that you are describing.

I solved it temporarily by loggin in to my providers "webmail" and deleted the
offending messages (one which came from the suse-linux-e mailinglist). I read
you could login to your provider with telnet and issue some commands to
delete the message as well (in case you don't have webmail-capability).

If anyone have a more detailed explanation as to why this happens I'd be very
interested as well. The problem doesn't seem all too uncommon on google, but
I've yet to find an explanation.


Arran


A little more detailed log (in case it helps):

fetchmail: incorrect header line found while scanning headers
fetchmail: SMTP> MAIL
FROM:<suse-linux-e-return-183983-arvid.johansson=bredband.net@xxxxxxxx>
BODY=7BIT SIZE=2510
fetchmail: SMTP< 250 Ok
fetchmail: SMTP> RCPT TO:<aj@localhost>
fetchmail: SMTP< 250 Ok
fetchmail: SMTP> DATA
fetchmail: SMTP< 354 End data with <CR><LF>.<CR><LF>
#fetchmail: message delimiter found while scanning headers
fetchmail: SMTP>. (EOM)
fetchmail: SMTP< 250 Ok: queued as 30C24505F
flushed
fetchmail: POP3> DELE 254
fetchmail: POP3< X-MDaemon-Deliver-To: suse-linux-e@xxxxxxxx
fetchmail: POP3> QUIT
fetchmail: POP3< X-MDAV-Processed: cbo-mail, Wed, 17 Mar 2004 08:08:21 -0500
fetchmail: client/server protocol error while fetching from pop3.bredband.net
fetchmail: 6.2.3 querying pop3.bredband.net (protocol POP3) at ons 17 mar 2004
16.37.12: poll completed
fetchmail: Query status=4 (PROTOCOL)
fetchmail: normal termination, status 4



torsdagen den 18 mars 2004 03.08 skrev Jesse Shaver:
> I have Fetchmail set up to run in Cron with the command ./usr/bin/fetchmail
> -sa > /dev/null 2>&1.. Every so often (3 times this week, but that is more
> frequent than it has been in the past) I realize that I have not received
> any email from the SuSE list in an unusually long amount of time. So I run
> Fetchmail manually. Often times I get this error message:
>
> 3 messages for j_shaver at mail.comcast.net (11629 octets).
> reading message j_shaver**AT**mail.comcast.net:1 of 3 (425 octets)
> fetchmail: message delimiter found while scanning headers fetchmail:
> timeout after 60 seconds.
> fetchmail: client/server synchronization error while fetching from
> Comcast.net fetchmail: Query status=7 (ERROR)
>
> So I log into Comcast web mail and find a malformed message like this one
(all headers are included below):
> > Date: Thu, 18 Mar 2004 00:47:16 +0000 (GMT)
> > X-Comment: Sending client does not conform to RFC822 minimum requirements
> > X-Comment: Date has been added by Maillennium
> > Received: from 200-153-199-126.dsl.telesp.net.br ([200.153.199.126])
> > by sccrmxc11.comcast.net (sccrmxc11) with SMTP
> > id <20040318004638s110067fhke>; Thu, 18 Mar 2004 00:47:13 +0000
> > X-Originating-IP: [200.153.199.126]
> > Message-ID: <s[9
>
> that is it. In the past I have tried to download these messages with
> Eudora, and it has been able to get them just fine, so I don.t know what is
> wrong. I realize that this is a malformed email, but I would like Fetchmail
> to get it anyways, and then filter it out with Procmail or something. Short
> of that, I would just like to set stuff up in such a way that Fetchmail
> does not fail silently, so at least I don.t have to guess when things are
> failing. I am Running SuSE 8.1 Pro, and am up to date on updates. Any
> suggestions would be appreciated.
>
> thanks in advance,

< Previous Next >
References