Mailinglist Archive: opensuse (3217 mails)

< Previous Next >
Lynx not working as browser in pine
I'm trying to get a url-viewer app to actually work in pine. The setup is:

SuSE 9.0
pine 4.58-16
lynx 2.8.4-510

I have enabled url (center area of pine Setup/Config page) and set the
url-viwer=/usr/bin/lynx at the last entry on that page. I chose lynx
because I prefer cli to gui and it can easily be used via ssh from both
linux and Win boxes (putty).

With a url highlighted in the body of a msg, pressing enter twice (select /
confirm) just flashes the screen without displaying the desired url. I have
searched on Google, finding only two messages from this forum dated in 2000
asking the same question without resolution to the problem then. The search
function for SLE archives is currently unavailable, but manually checking
several months headers for each of the past three years did not turn up
anything that seemed to be related.

I tried running strace with stderr redirected to a file. This didn't show
an attempted execution of lynx in the error traps, indicating that the
program call succeeded, but there was no display (or perhaps the screen
flash was lynx loading and immediately unloading).

I have also tried launching lynx from a shell script thinking that it might
need a shell in which to run. This may have some merit, because lynx was
visibly running, but displaying its default instruction page -- as if it had
been called w/o a target url. Here, I suspect that the child environment
did not receive the passed parameter from pine.

I'm stumped. Is there a way to do this or am I just flagellating a deceased
equine?

JimW



< Previous Next >
Follow Ups