Mailinglist Archive: opensuse (3217 mails)

< Previous Next >
Re: [SLE] Rhythmbox SOLVED
  • From: Donald Henson <wepin@xxxxxxxxx>
  • Date: Tue, 09 Mar 2004 14:03:49 -0700
  • Message-id: <1078866228.70.11.camel@xxxxxxxxxxx>
On Fri, 2004-03-05 at 14:37, Donald Henson wrote:

> On Fri, 2004-03-05 at 14:02, Anders Johansson wrote:
>
> > On Friday 05 March 2004 21.57, Donald Henson wrote:
> > > I've been trying to install Rhythmbox using Synaptic (apt gui). A search
> > > for rythmbox shows three packages: rhythmbox, rhythmbox-xine, and
> > > gst-player. I can install rhythmbox by itself or with gst-player but
> > > neither config works. If I install rhtyhmbox-xine, it doesn't work but
> > > it demands that I remove rhythmbox. What happens with any config is that
> > > when I run rhythmbox, I get a segmentation fault.
> > >
> > > It appears that a dependency is missing. Has anyone run into this
> > > problem? Does anyone have any thoughts on how to fix it? Any thoughts
> > > appreciated.
> >
> > rhythmbox-xine from usr-local-bin, together with xine from packman, works very
> > well for me. Maybe you don't have packman's libxine1 installed?
>
>
> I'm using rhythmbox from usr-local bin. Synaptic tells me that I have
> libxine1 (version 1_rc3a-0.pm.0) installed and that version is the same
> as the number of the latest version. So it appears that I have libxine1
> installed.
>
> Oh oh. I tried installing gxine. When I ran SuSEconfig, it stopped while
> 'removing obsolete Gnome/gtk files'. When I logged out and back in, I
> get an error message instead of a Gnome desktop. Does anyone know why
> gxine would cause this?
>
> Don Henson



First, ignore that last paragraph above. I don't know what happened but
the problem went away when I resinstalled everything. However, the
rhythmbox problem did not go away. It turns out it was a problem I ran
into before but, due to Synaptic upgrades, the error messages were
presented in a different format. I finally realize that this was an
earlier problem, solved using a suggestion from a list member. I'm
repeating the solution here to make it easy to find if you followed this
thread rather than the earlier one.

=====Included Text=====

>[snip]
>
>(rhythmbox:24133): Rhythmbox-CRITICAL **:
>/apps/rhythmbox/state/play_order gconf key not found!
>
>(rhythmbox:24133): Rhythmbox-WARNING **: Unknown value "" in GConf key
>"/apps/rhythmbox/state/play_order". Using linear play order.
>dhenson@linux:~>
>
>[snip]
>
>
I had this issue. You need to fire up the gnome configuration editor (on
Menu under System Tools), select apps and then rhythmbox and add a key
in the "state" folder with values of Key name: play_order and State:
linear. Or add linear if the key exists but with no value.

=====End Included Text=====

Don Henson

< Previous Next >