Mailinglist Archive: opensuse (4749 mails)

< Previous Next >
Re: [SLE] a way to get more verbose logging from the postfix procmail maildrop ?
  • From: David Corking <dcorking@xxxxxxxx>
  • Date: Tue, 27 May 2003 20:50:47 -0400 (EDT)
  • Message-id: <20030528005047.85069.qmail@xxxxxxxxxxxxxxxxxxxxxxx>
Patrick Shanahan <WideGlide@xxxxxxxxxxx> wrote

* <dcorking@xxxxxxxx> [05-26-03 21:27]:
>> When I upgraded from 7.3 to 8.2 I switched from
sendmail to postfix
>> on my dial-in workstation.
>>
>> I am getting errors from deferred mail that confuse
me. Is there a
>> way to get a more detailed log (in particular the
output of the
>> procmail command that seems to be causing temporary
failures.)


>man procmail:
>EXTENDED DIAGNOSTICS
> Extended diagnostics can be turned on and off
>through setting
> the VERBOSE variable.

thanks - I have tried to edit master.cd to make this
happen (as I am not sure which procmailrc is
executing.)

>> Here is an example of the message in /var/log/mail
>>
>> May 26 22:15:51 swanage postfix/pipe[17490]:
95A5D158AA:
>> to=<dcorking@xxxxxxxxxxxxxxxxxxx>,
orig_to=<dcorking@localhost>,
>> relay=procmail, delay=29812, status=deferred
>> (temporary failure)


>In my mail log, *deferred* only occurs on an error
(afaict) such as
>'name service error' or 'server dropped connection',
etc.

Thanks - this confirms my belief that it is a
misconfiguration and not anything intermittent wrong
with the network or the mail content.

>> How can I find out what is causing the failure? (it
is happening to
>> *all* my mail - hundred of different messages, and
happens repeatedly
>> as long as the mail is 'deferred'.)
>>
>> procmail never delivers the mail (it does not write

>> anything in its own log.)

This was an error on my part. If I have procmail
configured to log I get another problem :-

May 26 13:50:01 swanage procmail[3103]: Error while
writing to "/tmp/procmail.log"

May 26 13:51:13 swanage postfix/pipe[3102]:
7040B1580B: to=<dcorking@xxxxxxxxx>, rel
ay=procmail, delay=72, status=deferred (temporary
failure. Command output: procm
ail: Error while writing to "/tmp/procmail.log"
procmail: [3103] Mon May 26 13:5
0:01 2003 procmail: Assigning
"SENDER=myuser@xxxxxxxxx" procmail: Assigning "SHI
FT=1" procmail: Executing "/usr/bin/spamassassin"
procmail: [3103] Mon May 26 13
:51:13 2003 procmail: No match on "^X-Spam-Status:
Yes" Subject: Re: pls reply
to this Folder: **Requeued** 0 )


>If procmail does not log anything, procmail is not
being handed the
>mail or procmail is not available in $PATH or
permissions are wrong ???

I think this has me thinking along the right lines. I
decided to cause procmail more serious pain by moving
/etc/procmailrc

This time the error is more useful.

May 27 15:26:37 swanage postfix/pipe[7586]:
8BDA3158DF: to=<dcorking@xxxxxxxxxxxxxxx
.net>, orig_to=<dcorking@localhost>, relay=procmail,
delay=91655, status=deferred
(temporary failure. Command output: procmail: Couldn't
read "/etc/procmailrc" )

I think this means that procmail is executable (by
postfix) as required.

The permissions of /etc/procmailrc are
0644 (rw-r--r--) root root
so pipe/procmail should be able to read it.

I comment out the entire content of /etc/procmailrc
and the error goes back to this :-

May 27 16:09:01 swanage postfix/pipe[10016]:
AB92B1580D: to=<dcorking@xxxxxxxxxxxxxxxxxxx>,
orig_to=<dcorking@localhost>, relay=procmail,
delay=94382, status=deferred
(temporary failure)

It is pretty likely procmail is doing something bad
(or something incompatible with my postfix setup) but
I still don't know what.

I will try to get more explicit info on what happens
when I configure postfix for the local transport MDA
instead of procmail.

>Are you using fetchmail to get your mail?

Yes I am - configured by SuSEconfig. Are there common
pitfalls here?

Sequence of events was
1. install postfix - works
2. install spamassassin + configure - works with
fetchmail
3. postfix starts deferring messages (inbound +
outbound)

I have tried to take procmail out of the loop by
selecting POSTFIX_MDA=local in /etc/sysconfig/postfix
(this changes
mailbox_command = /usr/bin/procmail
to
mailbox_command =
in main.cf
)

but I am still getting similar log messages which
still mention procmail

May 27 20:37:01 swanage postfix/pipe[16479]:
980B415844: to=<dcorking@xxxxxxxxxxxxxxxxxxx>,
orig_to=<dcorking@localhost>, relay=procmail,
delay=110447, status=deferred (temporary failure)

(I have run SuSEconfig and rcpostfix restart)
Why is postfix still using procmail? Does postfix use
procmail for some other purpose than as an MDA?

(I notice that the master.cf created by YaST includes
these 2 lines

smtp inet n - n - - smtpd -o
content_filter=procmail:filter

...

procmail unix - n n - -
pipe
flags=R user=nobody argv=/usr/bin/procmail -t -m
/etc/procmailrc VERBOSE=on ${sender} ${recipient}

well actually the VERBOSE=on was added by me following
Patrick's advice - but the rest was from the YaST

I am afraid I don't understand the man pages as to
what these 2 lines mean so I am reluctant to change
them - any docs more suitable for newbies.)

David




__________________________________________________________
Lèche-vitrine ou lèche-écran ?
magasinage.yahoo.ca

< Previous Next >
This Thread
  • No further messages