Mailinglist Archive: opensuse (4749 mails)

< Previous Next >
Re: [SLE] jre library error
  • From: BandiPat <penguin0601@xxxxxxxxxxxxx>
  • Date: Mon, 19 May 2003 14:31:11 -0400
  • Message-id: <200305191431.11947.penguin0601@xxxxxxxxxxxxx>
On Monday 19 May 2003 13:07, Donn Washburn wrote:
> On the same topic
>
> I have SuSE 8.2 Pro and /usr/lib/BlackdownJava2-1.4.1/jre loaded.
> However, mozilla keeps giving a error.
> ---------------------------------------------------------------------
> LoadPlugin: failed to initialize shared library
> /usr/lib/BlackdownJava2-1.4.1/jre/plugin/i386/mozilla/javaplugin_oji.
>so
> [/usr/lib/BlackdownJava2-1.4.1/jre/plugin/i386/mozilla/javaplugin_oji
>.so: undefined symbol:
> _ZN16nsServiceManager23GetGlobalServiceManagerEPP17nsIServiceManager]
> =====================================================================
>= Is Mozilla or Blackdown the peoblem? According to mozilla.org
> Blackdown is the correct version to have.

> --
> 73 de Donn Washburn __ " http://www.hal-pc.org/~n5xwb "
**********************

Donn,
Is mozilla.org compiling with gcc 3.2 now? If they are still using gcc
2.95 to compile their mozilla, then quite likely that is your problem
as it will be incompatible with the Blackdown Java (compiled with
gcc3.2). The Blackdown works great with the SuSE Mozilla 1.4b rpms on
my setup.

BandiPat
--
--- KMail v1.5.1 --- SuSE Linux Pro v8.2 ---
Registered Linux User #225206
On any other day, that might seem strange...

< Previous Next >