Mailinglist Archive: opensuse (4749 mails)

< Previous Next >
Re: [SLE] Kernel compilation
  • From: Bruce Marshall <bmarsh@xxxxxxxxxx>
  • Date: Mon, 5 May 2003 07:45:08 -0400
  • Message-id: <200305050745.08551.bmarsh@xxxxxxxxxx>
On Monday 05 May 2003 03:17, Mariusz Jurgielewicz wrote:
> I am forced to compile kernel. SuSE 8.2 does not work properly on my
> machine out of the box. It fails to recognize network adapter and
> firewire drives. SuSE support said that network card configuration is
> not covered by Installation Support. Anyway I tried to compile kernel
> cause I know harware is working I got dual boot with Win2K on this
> machine and everything works fine.
>
> I got 2.40.20, plus 2.4.21-rc1 patch, plus ACPI patch from SourceForge.
> On my laptop USB 2 did not work until I made ACPI work so I got it just
> in case.
>
> 1. I did patches, renamed linux-2.4.20 to linux-2.4.21-rc1.
> 2. I did make mrproper
> 3. make xconfig did not work I had to change some things in
> /drivers/Config in and /drivers/net/Config.in
> 4. Finally it run but Firewire was copletelly grayed out.
> 5. I opened SuSE config from /boot/vmlinuz.config
> 6. No problems with make dep and make bzImage
> 7. I encountered many problems when I was trying to compile modules. I
> did not try to find patches. I disabled ATM, WAN and some IRDA support
> just to make it compile.
> 8. Installed modules, created initrd, duplicated and modified grub
> settings
> 9. Finally I was able to boot. Surprise, network card and firewire work
> perfectly but I lost my USB mouse, sound (I guess I had to compile ALSA
> separatelly).
>
> Are there any ways to to combine these 2 configurations? Shall I disable
> ACPI? I think all my problems are software related because my hardware
> works perfectly under Win2K and Knoppix.


Have you tried booting the SuSE kernel in SAFE mode? Or just turning acpi
off using the SuSE kernel?

Many people on this list have found that turning acpi off has cured problems
with their NIC's.


< Previous Next >