Mailinglist Archive: opensuse (4749 mails)

< Previous Next >
Re: [SLE] SuSE 8.2 --> Vanilla 2.4.20 kernel compilation fails??!!
  • From: Bruce Marshall <bmarsh@xxxxxxxxxx>
  • Date: Mon, 5 May 2003 07:36:39 -0400
  • Message-id: <200305050736.40149.bmarsh@xxxxxxxxxx>
On Monday 05 May 2003 01:01, Alex Daniloff wrote:
> Hello SuSE folks.
> Just today I updated my existing SuSE 8.1 to 8.2 version.
> Everything went very smoothly.
> However, when I tried to recompile plain vanilla 2.4.20 kernel from
> kernel.org, the compilation proceeded with a bunch of warnings like:
>
> warning: comparison between signed and unsigned
>
> and after a while it abruptly exited with errors.
> Interesting thing is that prior to this I recompiled and installed MySQL
> 4.0.12 DB from its sources from mysql.com without any problems.
> Could somebody please help me or give a hint how to solve this problem.
> I've noticed, that SuSE8.2 has a newer version of gcc 3.3.
> Could it be the case why kernel compilation fails?
> Thank you very much in advance.
> Alex

I have the same problem and I think it is due to the fact that the compiler
with 8.2 has been upgraded to 3.3. This (in my opinion) requires some
additions or changes to the makefile for 2.4.20. Haven't bothered to look to
see what those changes might be.


< Previous Next >
References