Mailinglist Archive: opensuse (4343 mails)

< Previous Next >
Re: re[2]: [SLE] SuSE machine haging with blinking leds
  • From: "Doug Glenn" <dglenn@xxxxxxxxxxx>
  • Date: Fri, 15 Nov 2002 14:50:36 -0500
  • Message-id: <web-1400203@xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx>
On Fri, 15 Nov 2002 11:30:52 -0800
Christopher Mahmood <ckm@xxxxxxxx> wrote:
* Doug Glenn (dglenn@xxxxxxxxxxx) [021115 10:09]:
Perhaps I mistated the exact tab name in Xconfig, but there is a tab labeled something like that and the functions are enabled on the default kernel.

It's a category of options, like "Block devices" or "Network
Support". Yes, sysreq support is in the kernel. No, it is not
turned on unless you explicitly do so.

Do this, run "make xconfig". Take a look at the last tab. This is the one with the label we were referring to. You will find the options enabled by default. (Kernel Hacking?)(I am not at the house at the moment, so I am going by memory which at my age is prone to senior moments <smile>)


Lets say for the sake of argument that the ACPI/APM code in my BIOS is defunct (worked with 8.0 fine). My only options are to disable that code and recompile the kernel.

No, you can disable it by booting with acpi=off.

Unfortunately you cannot do that.

Of course you can.

Don't forget the apm=off option as well. Tried both.

Doesn't work :) At least the lockups do not stop. Hence the effort to disable the power management code. I've read the SDB about this (first place I looked <smile>) and it has been an ongoing effort to fix it since. I can go as long as 36 hours without it happening, and it does not happen at all in the same kernel using Gentoo 1.2, so it has to be something in there, I just have yet to find it.

I'll be the first to admit it MAY NOT be this code. I am going by past experiance with the 7.3 kernel that did the same thing and using that command line fixed it, and then removing the resulting code options and recompiling fixed it. I am referring to the blinking caps lock and scroll lock under X. Unfortunately I have not found any other items in the SDB that may apply and I have seached Google for the issues related to the PCI_pin failures that result from disabling the code and trying to recompile. It is referenced with the acpi.h module.

I am going to go back and create a bootable floppy and hook my floppy drive back up so I can flash the BIOS with a higher rev I located. Perhaps this will fix the result and then I can be a happy camper :)

Doug
PS: Unlike some of the others, I have several more systems at home I can use, so it is just a major annoyance. This is the first time in years I've hit on something I cannot seem to fix on my own which is why I'm even reading this list for the first time since 98.

< Previous Next >
References