Mailinglist Archive: opensuse (4343 mails)

< Previous Next >
Re: [SLE] library dependency?
  • From: John Pettigrew <john@xxxxxxxxxxxxxxxx>
  • Date: Fri, 08 Nov 2002 10:41:44 GMT
  • Message-id: <fe941f924b.john@xxxxxxxxxxxxxxxx>
In a previous message, John Pettigrew wrote:

> In a previous message, Philipp Thomas wrote:
> > John, could you please run 'objdump -p jpilot' and post the output
>
> "objdump: jpilot: No such file or directory"
>
> Run as root.
>
> Do I need to provide the full path or something similar?

OK, with the whole path to jpilot, I get:

Dynamic Section:
NEEDED libdl.so.2
NEEDED libpisock.so.8
NEEDED libgtk-1.2.so.0
NEEDED libgdk-1.2.so.0
NEEDED libgmodule-1.2.so.0
NEEDED libglib-1.2.so.0
NEEDED libXext.so.6
NEEDED libX11.so.6
NEEDED libm.so.6
NEEDED libc.so.6



Which is odd - no reference to libcrypto at all!

However, the YaST tool gives the following info:

jpilot - Palm Pilot desktop for Linux

Installed Version
Version:
0.99.3-1

Provides:
libexpense.so.0
libkeyring.so.0
libsynctime.so.0
jpilot = 0.99.3-1

Requires:
/bin/sh
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
ld-linux.so.2
libX11.so.6
libXext.so.6
libc.so.6
libdl.so.2
libgdk-1.2.so.0
libglib-1.2.so.0
libgmodule-1.2.so.0
libgtk-1.2.so.0
libm.so.6
libpisock.so.8
libcrypto.so.0
libc.so.6(GLIBC_2.0)
libc.so.6(GLIBC_2.1)
libdl.so.2(GLIBC_2.0)
libdl.so.2(GLIBC_2.1)
rpmlib(CompressedFileNames) <= 3.0.4-1

Pre-Requires:
/bin/sh
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1

Obsoletes:

Conflicts:



Which *does* include libcrypto.so.0.

Does that help?

John
--
John Pettigrew Headstrong Games
john@xxxxxxxxxxxxxxxxxxxxxx Fun : Strategy : Price
http://www.headstrong-games.co.uk/ Board games that won't break the bank
Knossos: escape the ever-changing labyrinth before the Minotaur catches you!

< Previous Next >
Follow Ups