Mailinglist Archive: opensuse (4343 mails)

< Previous Next >
RE: [SLE] Please help with printing on my LAN
  • From: Art Fore <art_fore@xxxxxxxx>
  • Date: Wed, 6 Nov 2002 22:06:50 -0800
  • Message-id: <D0BE8C2BA20FFD4983B66331766009F86AD859@xxxxxxxxxxxxxxxxxx>
I have exactly the same problem using Netgear ps101 print servers and have
not yet solved it. Here is what I sent but got not answers. I have ran into
a dead end. Maybe this will help you or maybe you have some further intput.

I have a netgear ps101 print server on a network of 3 computers using NFS
and TCP/IP.

In Suse 8.0, it works fine, but in SuSE 8.1, connection tests OK, but no
test page is printed and I cannot print to it.

One difference I did notice, in SuSE 8.0, It is configured as Forwarding
queue to lp on LPD server 192.168.1.31. On SuSE 8.1, that selection is
not available or rather greyed out in the Advanced setup. Tried LPD
Filtering and forwarding queue and Direct TCP, but these do not work.

How would I get the LPD forwarding Queue so I can select it. CUPS is
installed the same on both machines and lprng is not installed on either
and both machines are using the same laserjet3 driver.

I found the following in the cups_error log.

I [03/Nov/2002:20:50:26 -0800] Job 3 queued on 'lp' by 'afore'.
I [03/Nov/2002:20:50:26 -0800] Started filter
/usr/lib/cups/filter/pstops (PID 26879) for job 3.
I [03/Nov/2002:20:50:26 -0800] Started filter
/usr/lib/cups/filter/cupsomatic (PID 26880) for job 3.
I [03/Nov/2002:20:50:26 -0800] Started backend /usr/lib/cups/backend/lpd
(PID 26881) for job 3.
E [03/Nov/2002:20:50:26 -0800] PID 26880 stopped with status 2!
I [03/Nov/2002:20:50:26 -0800] Hint: Try setting the LogLevel to "debug"

Finally found out how to set the debug level for cupsd. Below is what
appears to be relavent. Can anyone tell me what "D [04/Nov/2002:08:49:32
-0800] Insecure dependency in eval while running setuid at
/usr/lib/cups/filter/cupsomatic line 133." means and how I would correct
it?

0800] Cupsomatic backend version $Revision: 1.2 $ running...
D [04/Nov/2002:08:49:32 -0800] called with arguments:
'7','afore','(stdin)','1','media=Letter,Normal,Upper sides=one-sided'
D [04/Nov/2002:08:49:32 -0800] ppd=/etc/cups/ppd/lp.ppd
D [04/Nov/2002:08:49:32 -0800] Insecure dependency in eval while running
setuid at /usr/lib/cups/filter/cupsomatic line 133.
E [04/Nov/2002:08:49:32 -0800] PID 3273 stopped with status 2!
D [04/Nov/2002:08:49:32 -0800] Saw EOF!

Art


-----Original Message-----
From: Chris Carlen [mailto:crobc@xxxxxxxxxxxxx]
Sent: Wednesday, November 06, 2002 9:16 PM
To: SuSE
Subject: [SLE] Please help with printing on my LAN


Hi folks:

I am almost completed with migrating my home LAN and work computer to
8.1. the work computer was easy to set up printing, I just did a direct
print to TCP port and put in the IP of the network printer.

But at home I have 2 Linux boxes on a LAN, one with a printer (hostname
ting), and the other without (hostname tong). Of course, I want tong to
be set up to print to ting.

On 7.3 I used the LPD forwarding queues and all that. It was tricky,
but I got it to work.

Now with 8.1 and CUPS, I am stumped. I have done the following on the
server:

Set up the printer for local printing as printer "lp". It works fine
locally, on this machine.

In the "Printer administration for CUPS" window, went to "Advanced," and
selected "CUPS full server installation." Then went to the "CUPS server
settings" and added a browse address IP which is the IP of the other
machine, tong that I want to access this server.

Then set /root permiossions to allow from the IP of tong. Also set
permissions of /printers to allow from the IP of tong. /Admin has only
local permissions, and /classes allows from IP of tong also.

Finally I turned on browsing.

Then (as if that weren't enough) I set the printer service in inetd
configuration to active. And I have inetd running.

Is there something else I have to do?

Nothing was detected.Now on the client, I go to yast|printer. I let
it autodetect printers. So I go to "Configure..." and select "Show more
connection types..."

Now what?

If I click "LPD filtering and forwarding queue" then lookup LPD servers,
it finds the IP of the server. Things are looking hopeful. I type in
"lp" for "Name of the remote queue" and click the "Test remote LPD
access" button. It says the printer server is accessible.

I put in "lp" as the "Name for printing," and nothing for "Description
of printer" and nothing for "Location of printer" as there is already
the location in the previous "Connection" window. (We are now in the
"Queue name" window. If I proceed to set up a printer driver and test
printing, nothing comes out. If I put in a description and the of ting
in the "Queue name" window, still nothing comes out.

This isn't working.

Rather than get to the point of pulling my hair, I figured I'd come here
and see if you fine folks could tell me if there is something obviously
wrong. Or something not so obvious.

Your assistance will be greatly appreciated.

Good day!


--
_____________________
Christopher R. Carlen
crobc@xxxxxxxxxxxxx
Suse 8.1 Linux


--
Check the headers for your unsubscription address
For additional commands send e-mail to suse-linux-e-help@xxxxxxxx
Also check the archives at http://lists.suse.com
Please read the FAQs: suse-linux-e-faq@xxxxxxxx


< Previous Next >
Follow Ups