Mailinglist Archive: opensuse (4343 mails)

< Previous Next >
Re: [SLE] untangling X stuff
  • From: Curtis Rey <crrey@xxxxxxxxxxx>
  • Date: Wed, 6 Nov 2002 21:38:47 -0600
  • Message-id: <200211062138.47968.crrey@xxxxxxxxxxx>
Going into a non-X environment. Use the ftp program to go to
ftp://ftp.suse.com and then migrate to the supplementary dir. Make yourself
3 folder/directories and get the stuff in base, development, and
applications. If you want to be a little discriminating about the
applications you want to DL then pick and choose as you see fit. But I would
recommend getting everything in the stuff in base and devel dirs. You can do
the same for X and Gnome (it works best with X and kde).

Once you have done this rm everthing in your /tmp file, both root and user
stuff. Then go to the /home/<user> and do a rm -R .mcop and an rm .mcoprc
and go to the .kde and rm the socket-* and the tmp-* (whatever the * happens
to be). Then go back to the directories where the kde stuff is and into base
dir. Do a rpm -Uhv *rpm --force, then run SuSEconfig, repeat this for the
devel stuff and then the apps. You might also want to DL the stuff in the X
directory on the ftp site, especially anything to do with Sax and possibly
the wmlist (though you might not need it). Repeat as before and run
SuSEconfig.

Of course you can alwasy boot to the install cd and choose to update the
packages, Might have to do a manual selection and then choose the KDE stuff
and the X stuff and have the CD install it again. And you might want to see
if you have an other verstion of XF86Config in your /etc/X11 dir. On the
other hand you might have to create a new user name and dir in the home dir.

HTH Curtis

On Wednesday 06 November 2002 16:14, KMcLauchlan wrote:
> Group,
>
> In other messages, I have told how I somehow
> screwed-up my system (I was doing a big apt-get,
> with Synaptic in KDE3.0.3, SuSE8.0, when the
> locking screensaver activated, and when I returned
> from supper, my password no longer worked [on the
> screensaver], and I could not figure out how to do
> anything useful from the console that didn't kill
> X and my login, and when I shut down and re-started,
> KDM and GDM were no longer referenced and all I
> had was WindowMaker with many X-apps unusuable --
> as well as most K and most G apps).
>
> So, I've been trying stuff that I found here and
> there (Googling) about X, as well as suggestions
> that people have been offering to Tom N. and to
> other people with vaguely similar problems.
>
> Well, every time I try nearly anything, the response
> is something about Display :0.0 not being available,
> or similar.
>
> For example, when I open an xterm, use sux -, and
> attempt to invoke YaST2, I get this:
>
> # yast2
> Xlib: connection to ":0.0" refused by server
> Xlib: Protocol not supported by server
>
> y2controlcenter: cannot connect to X server :0.0
> #
>
> When I tried
> elefino@thisbox: > /opt/kde3/bin/startkde
>
> I get:
> Fata server error:
> Server is already active for display 0
> If this server is no longer running, remove
> /tmp/.X0-lock and start again.
>
> When reporting a problem....
>
> xinit: No such file or directory (errno2):
> no program named "/opt/kde3/bin/startkde" in PATH
> Specify a program on the command line or make sure
> that /usr/X11R6/bin is in your path.
>
> Now, obviously the first part is because I'm running
> the xterm from WindowManager. But, the rest... well,
> it's true that "startkde" is not there, or anywhere,
> according to "locate".
>
> I hoped to find a KDE3 executable, so I did
> # locate kde | less
>
> Well, there's nothing in /bin (the listing only
> began at /etc... and the only thing in /sbin is
> "conf.d/SuSEconfig.kde3-api".
>
> OK, so it's not an executable that you can run
> directly (or it's been erased...), and it's not
> that "startkde" thing that somebody suggested,
> because that isn't anywhere. So, when KDE is
> actually working, how does it happen? What is
> the sequence of "things that are started by
> other things until you have a KDE3 desktop
> staring you in the face"??
>
> I have dozens of directory containing many, many
> hundreds of kde2 files, and the same again for
> kde3. Apparently, something knew how to get to
> the heart of the business and rip out only the
> part that makes it all go, leaving the rest as
> useless clutter on my hard disk. Joy.
>
> Is there any point, at this point? Or should I
> just plug in the 8.1 DVD and say "New Installation"??
>
> /kevin

--
Billboard Writer vs. Literature = Micorsoft vs. Computing,


< Previous Next >
References