Mailinglist Archive: opensuse (4343 mails)

< Previous Next >
untangling X stuff
  • From: KMcLauchlan <kevinmcl@xxxxxxxx>
  • Date: Wed, 6 Nov 2002 23:14:59 +0100
  • Message-id: <20021106231459.3ec6c33f.kevinmcl@xxxxxxxx>
Group,

In other messages, I have told how I somehow
screwed-up my system (I was doing a big apt-get,
with Synaptic in KDE3.0.3, SuSE8.0, when the
locking screensaver activated, and when I returned
from supper, my password no longer worked [on the
screensaver], and I could not figure out how to do
anything useful from the console that didn't kill
X and my login, and when I shut down and re-started,
KDM and GDM were no longer referenced and all I
had was WindowMaker with many X-apps unusuable --
as well as most K and most G apps).

So, I've been trying stuff that I found here and
there (Googling) about X, as well as suggestions
that people have been offering to Tom N. and to
other people with vaguely similar problems.

Well, every time I try nearly anything, the response
is something about Display :0.0 not being available,
or similar.

For example, when I open an xterm, use sux -, and
attempt to invoke YaST2, I get this:

# yast2
Xlib: connection to ":0.0" refused by server
Xlib: Protocol not supported by server

y2controlcenter: cannot connect to X server :0.0
#

When I tried
elefino@thisbox: > /opt/kde3/bin/startkde

I get:
Fata server error:
Server is already active for display 0
If this server is no longer running, remove
/tmp/.X0-lock and start again.

When reporting a problem....

xinit: No such file or directory (errno2):
no program named "/opt/kde3/bin/startkde" in PATH
Specify a program on the command line or make sure
that /usr/X11R6/bin is in your path.

Now, obviously the first part is because I'm running
the xterm from WindowManager. But, the rest... well,
it's true that "startkde" is not there, or anywhere,
according to "locate".

I hoped to find a KDE3 executable, so I did
# locate kde | less

Well, there's nothing in /bin (the listing only
began at /etc... and the only thing in /sbin is
"conf.d/SuSEconfig.kde3-api".

OK, so it's not an executable that you can run
directly (or it's been erased...), and it's not
that "startkde" thing that somebody suggested,
because that isn't anywhere. So, when KDE is
actually working, how does it happen? What is
the sequence of "things that are started by
other things until you have a KDE3 desktop
staring you in the face"??

I have dozens of directory containing many, many
hundreds of kde2 files, and the same again for
kde3. Apparently, something knew how to get to
the heart of the business and rip out only the
part that makes it all go, leaving the rest as
useless clutter on my hard disk. Joy.

Is there any point, at this point? Or should I
just plug in the 8.1 DVD and say "New Installation"??

/kevin


< Previous Next >