Mailinglist Archive: opensuse (4343 mails)

< Previous Next >
Re: [SLE] library dependency?
  • From: Philipp Thomas <pth@xxxxxxxxx>
  • Date: Thu, 07 Nov 2002 02:11:19 +0100
  • Message-id: <6tejsuk8fv4annke42lq16j73rg2ofb0c6@xxxxxxx>
Anders Johansson <andjoh@xxxxxxxxxx> [Thu, 7 Nov 2002 01:38:30 +0100]:

>I'm sorry, but exactly what are you saying "Nope" to here?

OK, I was a bit too terse. That nope meant for ld doing something wrong.

>It's explicitly given.

OK, so it's done on purpose.

Any way, a binary linked to a dynamic library will have the soname
recorded in it's DT_NEEDED fields, so in this case jpilot (or whichever
program needs libcrypto) should have libcrypto.so.0.9.6 recorded, so I'm
wondering where the requirement for libcrypto.so.0 is coming from. Seems
to call for some testing.

Philipp

--
Philipp Thomas work: pthomas@xxxxxxx
Development SuSE Linux AG private: pth@xxxxxxxxx

< Previous Next >