Mailinglist Archive: opensuse (4343 mails)

< Previous Next >
Re: [SLE] Suse 8.0: only the gateway can be reached over internal network
  • From: "Peter Gloor" <pgloor@xxxxxxx>
  • Date: Sat, 2 Nov 2002 17:22:17 +0100
  • Message-id: <000f01c2828c$03b94120$0b0ba8c0@xxxxxxxxxxx>
Peter Gloor wrote on Friday, November 01, 2002 9:46 PM

> After a reboot I can no longer get any network connection
> over the LAN from/to a SuSE Linux server (SuSE Linux 8.0
> Professional).
>
> The server has two NIC's. One to the internet (eth0) the
> other two the internal network (eth1). Only the internal
> network is affected.
>
> While I still can ping between the gateway and the server
> I cannot ping between any other PC and the server using the
> internal network.
>
> Using YAST2 I made some changes in the configuration, but
> I'm not aware of having changed anything specific to the
> network or security configuration (actually I added another
> partition and made changes to the time configuration; that's
> all I remember).
>
> The gateway is a Windows NT server. All internal computers
> are configured to use this same gateway. Only the SuSE Linux
> server is affected by the problem. The configuration worked
> for months with SuSE 7.3 and it worked for about three weeks
> now with SuSE 8.0 as well.
>
> What could cause such a problem? Any hints?
>
> Peter

I just found a solution to my problem so I can give the answer
myself. Pointing the gateway address to the Linux Server itself
solved the problem.

The IP address of the gateway (a Windows NT server) on the
internal network is 192.168.11.1. The Linx servers internal
network IP address is 192.168.11.201.

My old configuration was:
Destination Gateway Genmask Iface
212.xx.yyy.192 0.0.0.0 255.255.255.240 eth0
192.168.11.0 192.168.11.1 255.255.255.0 eth1
0.0.0.0 212.xx.yyy.193 0.0.0.0 eth0

My new configuration is (this solved the porblem):
Destination Gateway Genmask Iface
212.xx.yyy.192 0.0.0.0 255.255.255.240 eth0
192.168.11.0 192.168.11.201 255.255.255.0 eth1
0.0.0.0 212.xx.yyy.193 0.0.0.0 eth0

Note: to protect our network from hackers some real numbers
have been replaced by xx.yyy in the example above.

Thanks for all the responses I've got.

Peter

< Previous Next >
References