Mailinglist Archive: opensuse (4343 mails)

< Previous Next >
Re: [SLE] Office Jet and CUPS
  • From: Kevin Donnelly <kevin@xxxxxxxxxx>
  • Date: Sat, 2 Nov 2002 16:01:07 +0000
  • Message-id: <200211021601.07522.kevin@xxxxxxxxxx>
On Saturday 02 November 2002 4:09 am, Tim Hanson wrote:
> That's what I thought, but when it gets to the devices, the ptal device
> isn't on the list. I even tried manually stopping cups, restarting
> ptal-init, then starting cups, all from the command line, but still no
> listing. It shows a JetDirect, an Apple, a couple of lpr / lpd choices,
> then all the parallel printers, all the usb printers, and finally a couple
> of Samba/Windows drivers. I found a configuration file in /etc/cups, but I
> don't know what to put there.

I was wrestling with this a couple of weeks ago for a HP PhotoSmart 7350, but
I haven't written up my notes yet. I took 12 hours to get it working,
although I could do it in 20 minutes now!

The hpojs 0.8-199 rpm supplied with SuSE 8.0 actually does not work at all
with the 7350 printer, and requires the hpojs 0.9 supplied with SuSE 8.1.
However, there is a bugette in that rpm, in that the ptal backend is not
symlinked to the new location of that backend. In /usr/lib/cups/backend, do
(as root):
ln -s /usr/sbin/ptal-cups ptal
PTAL should then appear in the list of protocols. This will probably solve
your issue.

You could also do it by brute force: set up a printer as if it were an lp
printer, and then go as root to /etc/cups/printers.conf and change the
DeviceURI to ptal:/mlc:whatever. This also works, but is of course not as
elegant!

I think the rpm (kindly provided by Klaas Freitag) is in the course of being
revised to deal with this and a few other small issues.The HPOJ site
(http://hpoj.sourceforge.net/) and mailing list are very good, and are worth
looking at, but I have to say it's a pretty weird setup HP has here.

HTH

Kevin

< Previous Next >
References