Mailinglist Archive: opensuse (4343 mails)

< Previous Next >
Re: [SLE] rpm dependencies after failed apt update
  • From: Richard Bos <allabos@xxxxxxxxxx>
  • Date: Sat, 2 Nov 2002 16:22:02 +0100
  • Message-id: <200211021622.02716.allabos@xxxxxxxxxx>
Op zaterdag 2 november 2002 16:01, schreef Andre Truter:
> Hi All,
>
> I use SuSE 8.0 with apt and synaptic.
>
> I have downloaded the latest sources.list file from
> http://linux01.gwdg.de/apt4rpm/ and did an update and upgrade.
>
> The upgrade failed. RPM returned an error. I think it was error 39.
>
> Now, I get the following errors when I try to upgrade packages one by
> one.:
>
> error: failed dependencies:
> arts-devel = 1.0.0-14 or arts-devel = 1.0.0-2 or arts-devel = 1.0.0-31
> or arts-devel = 1.0.0-59 or arts-devel = 1.0.1-13 or arts-devel =
> 1.0.1-23 or arts-devel = 1.0.3-4 is needed by arts-devel-1.0.4-4
> arts = 1.0.0-14 or arts = 1.0.0-2 or arts = 1.0.0-31 or arts = 1.0.0-59
> or arts = 1.0.1-13 or arts = 1.0.1-23 or arts = 1.0.3-4 is needed by
> arts-1.0.4-4
>
> When I try all upgradeable packages, the kdelibs3 package fails the md5
> check and nothing is upgraded.
> When I try a subset, rpm returns error code 39.

A quote about the the *-prpm components from the SuSE apt howto webpage
(http://linux01.gwdg.de/apt4rpm):

Drawback: APT will fail sometimes in case the to be patched rpm is
not installed... Workaround, just remove the component with the
suffix "-prpm" from the sources.list file, this will force apt to
download and install the full/normal rpm. It's now possible to
put the component with the "-prpm" suffix back (which is nice for
apt/download server) in the sources.list file.

The workaround for kdelibs is to "hold" it.
apt-get -o RPM::Hold::="kdelibs3" upgrade

Or to install all listed rpms manually using "apt-get install <pkgs>"


--
Richard



< Previous Next >
Follow Ups
References