Mailinglist Archive: opensuse (4348 mails)

< Previous Next >
Re: [SLE] CSS in Mozilla
  • From: Kevin L Hochhalter <kevin@xxxxxxxxxxxxxxxxxxxxxxx>
  • Date: Thu, 3 Oct 2002 11:14:25 -0700 (PDT)
  • Message-id: <Pine.LNX.4.44.0210031040540.28745-100000@xxxxxxxxxxxxxxxxxxxxxxxx>
On Thu, 3 Oct 2002, Thibaut Cousin wrote:

>
> Le Jeudi 3 Octobre 2002 18:57, Kevin L Hochhalter a écrit :
> > > It's OK so far, except for one detail: it completely ignores
> > > stylesheets. I guess it is an option somewhere in the preferences, but I
> > > haven't been able to find it. I remember that Netscape 6 and 7 behave the
> > > same by default. Where do you activate CSS-rendering in Mozilla?
> >
> > Css rendering is turned on by default, and should work "out of the box."
> > If you go to suse.com, and everything looks ok, then css is working. If
> > you are talking about user-defined style sheets, you will need to create a
> > file called userContent.css, and place it inside the chrome directory in
> > ~/.mozilla. You can then define whatever styles you wish, and they will
> > be applied to all of the pages that you visit. One thing you might need
> > to do is append "!important" to all of your styles to make sure that they
> > will override styles specified in the page you are viewing.
>
> I'm speaking about CSS on server-side, not user-defined.
> Are your sure they're on by default? I'm a newbie in webdesign, but I
> started to work on a small website with CSS. It renders correctly in
> Konqueror but not in Netscape/Mozilla (the stylesheet is plainly ignored: no
> background image, etc). I declared it as "text/css" in my HTML files, though.
>

This is kind of interesting. Does apt-get download and compile the source
for you? I have always used a binary from mozilla.org. Perhaps something
compiled incorrectly? Have you visited other web sites using Mozilla, and
do they render correctly? Perhaps there is something in your code that is
not quite right. I tossed a page up on one of my servers that you can use
to verify if css rendering is working. I pulled up this page on my
workstation using Mozilla 1.1, Phoenix 0.2, Opera 6.x, and Konqueror, and
it looks fine. Follow this link, and let me know how it looks.

http://www.worshipthebean.com

Kevin


< Previous Next >
References