Mailinglist Archive: opensuse (4348 mails)

< Previous Next >
Can't mount CDs under SuSE 8.1
  • From: John Pettigrew <john@xxxxxxxxxxxxxxxx>
  • Date: Thu, 03 Oct 2002 13:48:03 +0100
  • Message-id: <730da17f4b.john@xxxxxxxxxxxxxxxx>
A confirmation and amplification of yesterday's report.

Has anyone else installed SuSE 8.1 and found problems mounting CDs? I cannot
mount any CDs on my newly installed system - on issuing "mount /dev/dvd" as
user, I get the error "/dev/dvd: Input/Output error. mount: I could not
determine the filesystem type and none was specified". A similar report is
produced when logged in as root ("/dev/dvd: Input/Output error. mount: you
must specify the filesystem type").

AFAICT, the system doesn't try to access the drive before making this report
(no lights flicker). Using "mount -t iso9660 /dev/dvd /media/dvd" hasn't
helped - the error here is "wrong fstype, bad option, bad superblock on
/dev/dvd or too many mounted filesystems". The relevant lines in /etc/fstab
seem OK (e.g. "/dev/cdrom /media/cdrom auto ro,noauto,user,exec 0 0").
Mounting the floppy works fine, even though it also has "auto" in fstab.

Mounting /dev/cdrecorder (my other CD drive) gives a "mo medium found"
error, even though I've tried with 2 different CD-ROMs. At least this drive
allows a simple "mount /dev/cdrecorder" without complaining that I've not
specified the fs type, though.

The only other thing I can think is that /etc/filesystems is important. The
man page suggests that this is only used after it's tried all the
filesystems anyway, but my /etc/filesystems only contains the five lines
"vfat, hfs, minix, reiserfs, *". Do I need to add anything to this?

Any ideas? It all worked without a hitch with 7.3.

TiA,

John
--
John Pettigrew Headstrong Games
john@xxxxxxxxxxxxxxxxxxxxxx Fun : Strategy : Price
http://www.headstrong-games.co.uk/ Board games that won't break the bank
Knossos: escape the ever-changing labyrinth before the Minotaur catches you!

< Previous Next >
Follow Ups