Mailinglist Archive: opensuse (3378 mails)

< Previous Next >
How to make CUPS work for Canon PS (not in supported list)
OK, much removing and re-installing, and CUPS admin
now responds to my root password. This is progress.

Now what? How do I make printing happen?

My printers are all networked, and are all Canons
(none of which appear in the supported list),
and all of them are on network segments OTHER
than the one I'm on (meaning, they do not appear
when YaST2 tries to detect "local" printers --
has SuSE never heard of VLANs?).

So, what do I put in a URI?

Here's what I know about one printer:
it's a Canon ImageRunner 550, and it lives
at 172.16.11.20

I have a PPD file that comes from the Canon CD
that's labeled "Network Printer Board-F1 (PostScript).
One helpful web page suggested that when using Windoze
ppd files in Linux, the best choice might be the
Win 2000 files... but all copies of the PPD on the
CD seem to be the same file.

I previously tried to create/configure some printers
in YaST2 for CUPS. It did not go well, but it DID
result in a .ppd file being created for each attempt
in /etc/cups/ppd/

So, I copied the Cannon PPD (EFMC6A20.PPD) to /etc/cups/ppd
and restarted YaST2. I was hoping that this would cause
another printer instance to appear in the list that
YaST2 presents for editing/adding. Didn't work. There
must be another file or flag somewhere.

I tried renaming the file to lowercase (to match what the
other .ppd files look like). Didn't work.
I tried changing the permissions -- basically removing "x"
from world -- to match the other .ppd files that were created
by YaST2, and which show up in the YaST2 Hardware, Edit Printers
dialog. Didn't work.

Also, the main list of "supported" printers seems to be
an enormous database file. I don't know how to get my
Canon ppd file included in the list, so that I could
"Choose Model" in the YaST2 interface.

Can somebody tell me what I'm really supposed to be doing here?

What I want to accomplish is to print documents (mostly
postscript, but some plain ASCII and some images)
to that networked printer. How do I invoke the magic,
so that when I hit the "Print" button in KWord, or when
I write "a2ps <filename>" in a terminal... the desired
printing..... happens?

One of the approaches, via the menus, gets me to a
dialog that demands a URI. That's nice, except I
don't know what I'm supposed to fill in. The help for the
web-based cups Admin was even nice enough to supply a
bunch of EXAMPLE URIs... but, they don't really help me.

I look at them and don't understand which of the six or
eight examples I'm supposed to choose (or why it makes
a difference), and then I don't understand which parts
are supposed to be written verbatim, and which parts
are supposed to be replaced by something that is
relevant to my computer and my network.

I mean, I can probably eliminate the example URIs that
seem to relate to HP JetDirect, because I know I
don't have HP printers, but what about the others?

I would be happy to get basic, generic PS printing
happening, to begin. Later, I can worry about duplexing.
I don't even need printing to be as carefree as Windows.
I just need to stop rebooting into windows every time
I have something to print. Yuck!

What do other people do when their printer does not
appear in the existing "supported" list, in YaST2?

If there's a document somewhere that explains all this,
just tell me the title.

Thank you.

/kevin

PS: My cube-neighbor, who is a bit of a UNIX guru,
loaded Red Hat and printed within moments, using
printconf. Months ago, when I loaded SuSE 7.3
onto this laptop, I chose CUPS because people said
it was easier and more pleasant.
Every time I turn around, I'm
encountering yet another ordinary thing that
Red Hat seems to do easily, out-of-the-box, while
SuSE makes me struggle or makes me fail permanently.
Is it something I said? :-)




< Previous Next >