Mailinglist Archive: opensuse (3644 mails)

< Previous Next >
Re: [SLE] Updated Kernel, lost old /lib/modules/2.4.10-4GB
  • From: Anders Johansson <andjoh@xxxxxxxxxxxxxxxxxxxxx>
  • Date: Sat, 16 Mar 2002 08:16:27 +0100
  • Message-id: <200203160816.27790.andjoh@xxxxxxxxxxxxxxxxxxxxx>
On Saturday 16 March 2002 05.24, Terry Eck wrote:
I updated to the new kernel k-deflt-2.4.16-22.i386.rpm using
rpm -Uvh as per the instructions in
http://sdb/suse.de/en/sdb/html/ftpkernel.html
I copied vmlinuz and initrd to vmlinuz.old and initrd.old
Modified lilo.config to include vmlinuz.old. The problem
is the directory /lib/modules/2.4.10-4GB has been erased
during the update. I do not think this is correct because
no I lost all the modules for the old kernel (2.4.10-4GB).
I have not tried to use the old kernel (new one works great)
but have a feeling that it would not work because of missing
modules. Can anyone tell me if this is a bug or am I missing
something about modules?
Thanks
Terry

No you're not missing anything about modules. But rpm works that way. the bug,
if you can call it that, is in the procedures. If you're going to use those
procedures on that web page and expect to have any use of the .old-files you
backed up, you will have to add this to the procedures:

before rpm -Uvh, mv /lib/modules/2.4.10-4GB /lib/modules/2.4.10-4GB.old

do rpm-Uvh

mv /lib/modules/2.4.10-4GB.old /lib/modules/2.4.10-4GB

This is because -Uvh will remove previous incarnations of the package before
installing the new one. This will prevent that from deleting the modules.

Another way of achieving the same effect could be to use -ivh --force, but I
haven't tried that. -ivh won't uninstall anything, but you will get a
duplicate entry in the rpm database for k_deflt. Neither method is anything
more than a workaround, really.

//Anders

< Previous Next >
Follow Ups
References