Mailinglist Archive: opensuse (3644 mails)

< Previous Next >
Strange PPP and wvdial problems....
Hi

I am using wvdial to connect to my isp and I am experiencing some windows
type problems i.e. it seems to work every now and then....I was wondering if
anyone could shed any light on the following.

When I try to connect using wvdial it normally takes at least 3/4 attempts
to connect using pppd. The error message I get is usually :

The PPP daemon has died: A modem hung up the phone (exit code = 16)

Here is the output from the screen:

--> WvDial: Internet dialer version 1.41
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: AT Q0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
AT Q0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Sending: ATM0
ATM0
OK
--> Modem initialized.
--> Dialing MyServer .
--> Sending: ATDT83388463
--> Waiting for carrier.
ATDT83388463
CONNECT 28800 NoEC
?~?~?~?~?~?~?~?~?~?~

Here is the contents of /var/log/messages:

Mar 8 08:23:20 linux pppd[11308]: using channel 8
Mar 8 08:23:20 linux pppd[11308]: Using interface ppp0
Mar 8 08:23:20 linux pppd[11308]: Connect: ppp0 <--> /dev/ttyS0
Mar 8 08:23:20 linux pppd[11308]: sent [LCP ConfReq id=0x1 <asyncmap 0x0>
<magic 0xffe4e725> <pcomp> <accomp>]
Mar 8 08:23:51 linux last message repeated 15 times
Mar 8 08:24:35 linux last message repeated 22 times
Mar 8 08:24:37 linux pppd[11308]: Hangup (SIGHUP)
Mar 8 08:24:37 linux pppd[11308]: Modem hangup
Mar 8 08:24:37 linux pppd[11308]: Connection terminated.
Mar 8 08:24:37 linux pppd[11308]: Exit.

So normally I hear modem dialing through, trying to connect then finally I
get the exit code 16 and it hangs up. This happens 3/4 time then it
connects up and works fine. Can anyone point me in the right direction as
to why this is happenning - its not a show stopper, just really annoying.

Cheers

Dan



< Previous Next >
This Thread
  • No further messages