Mailinglist Archive: opensuse (4053 mails)

< Previous Next >
Re: [SLE] Depmod -a on new 2.4.7 kernel
  • From: StarTux <matthew@xxxxxxxxxxxxxxx>
  • Date: Mon, 20 Aug 2001 01:14:15 -0700
  • Message-id: <3B80C6D7.5030509@xxxxxxxxxxxxxxx>
Milnes Terry SSgt 52 OSS/OSOMS wrote:

As stated in another thread, I upgraded my kernel to the new 2.4.7 kernel.
However, now I cannot do a depmod -a. It says that it cannot find the
modules for 2.4.0-?GB. How do I fix this?

NeoFax

If its not there can you do this:

uname -a

This will give you the current Kernel that is running.


Goto: /lib/modules/<kernel version>

If the directory is there please go into that directory

This is mine:

/lib/modules/2.4.7-4GB > ls
build modules.dep modules.parportmap net kernel modules.generic_string modules.pcimap pcmcia misc modules.isapnpmap modules.usbmap thinkpad

If this does not exist did you do a modules modules_install?

My way of doing kernel upgrades, not totally recomended as its risky:

make cloneconfig
make menuconfig

Now I go in and double check.

make dep clean modules modules_install

It will do each step in order.

Finally:

make install

This does all the steps, including installing the new kernel to /boot and running lilo. Do the mk_initrd again and lilo again to make sure.

This usually works for me.

Matt


< Previous Next >