Mailinglist Archive: opensuse (4053 mails)

< Previous Next >
rpm incompatibility
  • From: pierre@xxxxxxxxx
  • Date: Thu, 2 Aug 2001 13:58:10 +0200 (CEST)
  • Message-id: <15209.16466.12375.907624@xxxxxxxxxxxxxx>
Hi, Im new to this list, I couldnt find archives for the list, and I
apologize if my question has already been debated.
I have SuSE 7.0, and made no upgrade.
I recently wished to install or upgrade some pieces of software, so I
found and downloaded the corresponding rpm packages, but I could not
install them! rpm issued:
only packages with major numbers <= 3 are supported by this version of
RPM
Indeed I have an rpm version 3.0.4, indeed there is a 4.0.x rpm
version out, indeed the packages I wanted to install were built with
this new version.
Some probes on different sources showed me the problem has been met by
others, the recommended solution being to upgrade first to 3.0.5,
hence to 4.0.x
I feel uneasy at upgrading rpm: its central, its tricky, I have no
deep knowlege of its structure, and I fear to harm my installation, or
to spend a lot of time.
I dont understand why there is not more noise about it. rpm.org
website doesnt even mention it. Not a word either on SuSE support
database. Has SuSE 7.1 adopted the new rpm? Am I a fool not to adopt
the new distrib, if I dont need it?
please give feedback!
--
Pierre Imbaud <pierre@xxxxxxxxx>
12 Rue des Bosquets 91480 Quincy Sous Sénart France
Tel: 01 69 00 94 57 Fax 09 47


< Previous Next >
This Thread
  • No further messages