Mailinglist Archive: opensuse (3637 mails)

< Previous Next >
Re: [SLE] NVIDIA drivers (again!) and unresolved symbols
  • From: matthew johnson <matthew@xxxxxxxxxxxxxxx>
  • Date: Tue, 29 May 2001 12:57:22 -0700 (PDT)
  • Message-id: <Pine.LNX.4.33.0105291255450.31047-100000@xxxxxxxxxxxxxxxxxxxx>
Try doing "make clean" and see if that clears anything out of the
configuration. Not tried this yet though.

I got an unresolved symbol too, in a module I never use..So it got
deleted. Definately strange to get these.

Don't think I had a problem wiht the src.rpm though.

Matt

On Tue, 29 May 2001, Paul Abrahams wrote:

> For about the fourth time I've tried to generate and install
> the NVIDIA drivers (newest version, 1251). And each time
> things get worse. The main problem I have is with the
> kernel module. When I attempt to install it I get a
> notification of an unresolved symbol _mmx_memcpy. Until
> the most recent iteration I could still get the server to
> run, albeit defectively. But now it won't run at all -- I
> get the message "failed to initialize the NVdriver kernel
> module". Supposedly that's because I'm using the wrong
> header files, but the generation scripts seem to indicate
> that the correct kernel include files are being summoned.
>
> I've tried doing the install using both the rpm's and the
> tar files, with essentially the same result either way.
> I've also tried specifying the include files explicitly with
> the SYSINCLUDE parameter. The only difference I've found
> between using the rpms and the tarfiles is that the rpms put
> the NVdriver module in
> /lib/modules/2.4.4/kernel/drivers/video while the tarfiles
> put it in /lib/modules/2.4.4/kernel/video, one level higher
> in the tree.
>
> For now I've reverted to the XFree driver, but it has its
> own set of problems.
>
> I'm puzzled both as to how to get past these problems and
> why they should be getting worse.
>
> Paul
>
>
>
> --
> To unsubscribe send e-mail to suse-linux-e-unsubscribe@xxxxxxxx
> For additional commands send e-mail to suse-linux-e-help@xxxxxxxx
> Also check the FAQ at http://www.suse.com/support/faq and the
> archives at http://lists.suse.com
>


< Previous Next >
Follow Ups
References