Mailinglist Archive: opensuse (3637 mails)

< Previous Next >
Re: [SLE] kde-config not found error - found a solution
Well after a lot of searching I found a solution.. thought it would be worth
posting in case someone else runs into this problem. This was posted by Eric
Laffoon (Quanta web developer) on 26 Feb 2001 (found the posting in a search
at kde.com)

The are two possible solutions to this problem:
1. Type:
locate kde-config
export KDECONFIG=$KDEDIR/share/config/kde-config (or your path)
./configure

2. If you have an old version of kde2 without kde-config edit
config.cache and add these two lines:
kde_cv_path=${kde_cv_path=/opt/kde/bin/kde-config}
kde_cv_path_kde_config=${kde_cv_path_kde_config=/opt/kde/bin/kde-config}

Run ./configure again - configure will read the data from
config.cache and will not check for kde-config

The second solution worked for me, and configure ran without generating any
more errors. Make on the other hand is happy generating pages of errors. I
don't know if they are related to the tweak to config.cache or other
problems... haven't looked into it yet.

Later
C.


On Thursday 24 May 2001 16:02, Clayton Cornell wrote:
> Hmm interesting frustration with an install happening here. I downloaded
> the source for KMyMoney. Not having much success doing the install though.
> I run ./configure, and it chugs through everything until it exits with
> this error message:
> -----------------------------
> checking for kde-config... not found
> configure: error: The important program kde-config was not found!
> Please check whether you installed KDE correctly.
> -----------------------------
>
> echo $KDEDIR gives me /opt/kde2
> locate kde-config tells me the file is in /opt/kde2/share/config
>
> Seems normal.....
>
> I have searched through the various archives and came up with a suggestion
> to export $KDECONFIG=/opt/kde2/share/config. That didn't seem to make a
> difference.
>
> Anyone have any ideas or suggestions here? What's the obvious that I
> missed?
>
> Clayton

< Previous Next >
References