Mailinglist Archive: opensuse (3637 mails)

< Previous Next >
Re: [SLE] smbclient: Short read when getting file
  • From: "Harold !" <ambrosius1972@xxxxxxxxxxx>
  • Date: Tue, 22 May 2001 04:02:50 -0500
  • Message-id: <F265SxvjPkQTGpaoG1V000005b4@xxxxxxxxxxx>
You do have WRITE permissions on that directory in NT right?
I had no such troubles in samba 207 haven't tried with the new SaMBa yet. Also. if you do have write access to that directory (as that user) try it using a mount command. Personally I hate the smbclient.

mount -t smbfs \\\\nt-server-name\\share-name /mount-point -O username=_username_,password=_password_

I use this in a script on my system.

Hope this helps
AMbrosius


From: "Konstantin (Kastus) Shchuka" <kastus@xxxxxxxxx>
To: suse-linux-e@xxxxxxxx
Subject: [SLE] smbclient: Short read when getting file
Date: Mon, 21 May 2001 18:30:02 -0700
MIME-Version: 1.0
Received: from [202.58.118.3] by hotmail.com (3.2) with ESMTP id MHotMailBCD30C26001B4004378FCA3A760308EA0; Mon May 21 18:30:14 2001
Received: (qmail 13915 invoked by alias); 22 May 2001 01:30:05 -0000
Received: (qmail 13908 invoked from network); 22 May 2001 01:30:05 -0000
From suse-linux-e-return-58208-ambrosius1972 Mon May 21 18:30:48 2001
Mailing-List: contact suse-linux-e-help@xxxxxxxx; run by ezmlm
Precedence: bulk
X-No-Archive: yes
list-help: <mailto:suse-linux-e-help@xxxxxxxxxxxxxx>
list-unsubscribe: <mailto:suse-linux-e-unsubscribe@xxxxxxxxxxxxxx>
list-post: <mailto:suse-linux-e@xxxxxxxx>
X-Mailinglist: suse-linux-e
Delivered-To: mailing list suse-linux-e@xxxxxxxxxxxxxx
Message-ID: <20010521183002.A3459@xxxxxxxxx>
Mail-Followup-To: suse-linux-e@xxxxxxxx
User-Agent: Mutt/1.3.12i

Hi there,

I got a weird problem with smbclient.

The setup is as follows:

I am accessing a share on WinNT 4.0 PDC (service pack 6) with smbclient
2.0.8. I have no problems getting to smb: \> prompt, but I can neither
write to the share, nor read from it.

Reading finishes in:

smb: \> get shortfile.txt shrt.txt
getting file shrt.txt of size 44 as shrt.txt Short read when getting file \shortfile.txt. Only got 0 bytes.
(0 kb/s) (average 0 kb/s)
smb: \>

Put command gives:

smb: \> put shortfile.txt s.txt
putting file shortfile.txt as \s.txt Error writing file: code 0
(0 kb/s) (average 0 kb/s)
smb: \>

I can do ls on that share:

smb: \> ls
. D 0 Mon May 21 18:31:00 2001
.. D 0 Mon May 21 18:31:00 2001
download D 0 Mon May 21 16:20:07 2001
s.txt A 44 Mon May 21 18:31:00 2001
shortfile.txt A 44 Mon May 21 17:55:00 2001
uGuardClient.exe A 3993175 Wed Apr 18 19:55:28 2001

61185 blocks of size 262144. 29759 blocks available
smb: \>

I tried smbclient from smbclnt-2.0.7 and 2.0.8 from SuSE with the same result.

On WinNT side I get an error message in system log: ``The server
received an incorrectly formatted request from \\LINUX''.

What might be wrong with smbclient?

-Kastus (very puzzled)

--
To unsubscribe send e-mail to suse-linux-e-unsubscribe@xxxxxxxx
For additional commands send e-mail to suse-linux-e-help@xxxxxxxx
Also check the FAQ at http://www.suse.com/support/faq and the
archives at http://lists.suse.com


_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com


< Previous Next >