Mailinglist Archive: opensuse (3637 mails)

< Previous Next >
Has anyone been able to compile php-4.0.5 on SuSE 7.1?
  • From: wilson@xxxxxxxxxxx (Jonathan Wilson)
  • Date: Mon, 21 May 2001 21:32:42 -0500
  • Message-id: <5.1.0.14.0.20010521212914.032b70f8@xxxxxxxxxxxxxxxx>
Howdy,

I'm trying to compile php-4.0.5 on SuSE 7.1 and I'm having boatloads of trouble. I've finally hit one error that's in php it's self so I'm totally stuck:

gd.c:91: conflicting types for `gdIOCtx'
/usr/include/gd_io.h:18: previous declaration of `gdIOCtx'

I have a feeling it has something to do with my versions of glibc and GCC. More and more often I find that I'm able to compile things on one distro, but not another, and vice versa. I think the distros are becoming more fragmented, at least as far as major libs and GCC are concerned. I hope all this works it's self out soon after GCC 3.0 comes out.

Anyway, has anyone been able to compile php 4.0.5 from source?

----------------------------------------------------
Jonathan Wilson
System Administrator

Cedar Creek Software http://www.cedarcreeksoftware.com
Central Texas IT http://www.centraltexasit.com


< Previous Next >
Follow Ups