Mailinglist Archive: opensuse (3637 mails)

< Previous Next >
GLIB 2.1 > GLIB 2.2
I would like to upgrade SuSE70 glibc 2.1 to 2.2 .
Then if glibc 2.1 binaries work with glibc 2.2 , would I still have a large number of binaries,or applications that
are looking for links to the older libraries ?
I had problems with kvirc when I tried shared libraries package 71 from suse-ftp,
(couldn't find libstdc++ something ) I accidently mis-took it for the update suggested in the kernel Changes file . )

I suppose I could upgrade to the newer KDE as well, along with glibc 2.2 .
But it's really the binaries behind the scenes , running processes, system dependent, and other important
scripts, or whatever, which I worry about causing unecessary problems .
am I being too paranoid , or what ?

New Kernels, [2.4.4-series] also suggest upgrading to glibc 2.2 .
This is my main reason for upgrading, and I also need gcc 2.95.3 which requires glibc2.2 .

So Is ti too much to fuss with at this time ?
if not I would appreciate any suggestions, warnings, and advice

> On Thu, May 10, 2001 at 10:06:59AM -0400, James Davis wrote:
> > I am trying to install Firestarter for Suse.. 6.4 and it says it needs a
> > GLIB 2-2 or greater.. where can I find this and what else must I install for
> > this to work on SUSE 6.4?

* Konstantin (Kastus) Shchuka
> Not an easy thing. IIRC, you can't have both glib2.1 and 2.2. If you want> to install glib2.2 you have to recompile
> all binaries on your system. If you need glib2.2 the easiest way is to upgrade to SuSE 7.1

* Mads Martin Joergensen
> A little correction; glibc 2.1 binaries work with 2.2 -- it is the otherway around it does not work.

< Previous Next >
Follow Ups