Mailinglist Archive: opensuse (3637 mails)

< Previous Next >
RE: [SLE] Modules won't load.
  • From: "Shonne Beavers" <shonne_beavers@xxxxxxxxx>
  • Date: Wed, 9 May 2001 12:57:42 -0500
  • Message-id: <GIEKKDFCNMGMFPLMHBPMCECPCAAA.shonne_beavers@xxxxxxxxx>
I tried that already. The System.map is created as /boot/System.map. Should
I delete this when I compile another kernel. Typically, what I do is I
delete the old kernel modules. Then I run make menuconfig. After that I run
make dep clean bzImage. Finally I run make modules modules_install bzlilo.
Then I reboot. Did I miss something?



Shonne Beavers wrote:
>
> I am using SuSE 7.1 with kernel 2.4.2. I recompiled it with 4GB memory and
> SMP. So this creates the modules in /lib/modules/2.4.2-4GB-SMP. The
problem
> is that machine 'wants' to load modules from /lib/modules/2.4.2. How do I
> correct this? I have rebuilt the kernel about 4 times, same problem.
>

Try this command:
/sbin/depmod -ae -F /boot/System.map-2.4.2-4GB-SMP 2.4.2-4GB-SMP
It assumes the System.map file for your kernel is
/boot/System.map-2.4.2-4GB-SMP.
I don't know for sure if it is or not.

Mark

--
To unsubscribe send e-mail to suse-linux-e-unsubscribe@xxxxxxxx
For additional commands send e-mail to suse-linux-e-help@xxxxxxxx
Also check the FAQ at http://www.suse.com/support/faq and the
archives at http://lists.suse.com


< Previous Next >
References