Mailinglist Archive: opensuse (3104 mails)

< Previous Next >
Re: [SLE] samba network server locking up an big file transfers
  • From: samelash@xxxxxxxxxxxxx (Samy Elashmawy)
  • Date: Sun, 23 Apr 2000 10:18:48 +0000
  • Message-id: <3.0.3.32.20000423101848.00f836ac@xxxxxxxxxxxxxxxxxx>



Sorry I havent gotten to it yet , as the only time I copy big files iw when
I DL something off the internet.
samba server (P166 64 ram and 2.5 gig hd linksys etherfast 10/100 card)

I have problems when

1/ coping a large file from the samba server to the windows workstation

2/ copying a large file from the samba server to a linux workstation

Someone susgested the follwoing , but I havent had a chance to look into
it. Nor have I had a chance to swap the cable or card yet.

Funny thing is when I connected a linux box to the network and tried
copping the file from the windows workstation and it copyed fine. So the
only common thing is the samba machine.

I might just copy the data , format the drive , and load up 6.4 and see
what happens. This box has gone from 6.0 to 6.2 to 6.3 so it may be some
flakey config thing.

Any one know how to copy a dir along with all the sub dirs with out chnging
all the filw owners and permisions ext... that way I can move it to another
box , and copuy it later.

otherwise I can zip it up on the windows box , and later unzip it back to
the linux box ?

Sugested fix form From: Marcel Broekman <marcelbr@xxxxxxxxxxxx>

I remember i had the same problem a few years ago. Didn't use Linux at
that time. I had a NT-server and a few win95 clients. The server was
also used as a dialup server to the Internet. I had read somewhere how
to "tune" the dialup connection and get a better throughput. This was
done by changing the value of MTU (Maximum Transfer Unit) and RWIN
(Receive Windows?) in the windows registry. If i remember correctly
MTU was set to 1500 by default. Changing this value to 576 would
increase the speed. I didn't edit the registry by hand but downloaded
a utility that could do this for me. Soon after changing the value i
experienced the same problems you are describing. The utility had
changed not only this value for the dialup connection but also for for
the network. Changing this value back to default solved this annoying
problem.
I don't know if this could also be a problem in your setup with Linux
and don't want to put you on the wrong track, but maybe it is worth
checking. Needless to say checking your cabling and hardware would be
your first step. Let me know how thing go.

HTH, Marcel

At 10:39 AM 4/23/2000 +0100, dids wrote:
>Hi i dont know if you've solved this problem yet Ive only just found these
>email groups <sigh>
>
>Ive had exactly the same problem since upgrading my 10mbps up to 100mbps
>cards and hub
>I have a intel233 as the server processor
>
>I noticed that both AtalkD ( Appletalk ) and Samba had the same problem, so
>I concluded
>that i must be a networking problem not a Samba problem. I also noticed that
>I didnt have
>the problem if I copied from win9x machine to win9x machine. So the hub and
>wiring must be ok.
>
>After scratching my head. I looked in the Kernel and there is an option, to
>throttle the network
>if you think the processor isnt up to the speed of network transfer. It says
>even a 10mbps network
>can overload a slower processor.
>
>I switched this kernel option on and this seems to have worked. I still get
>much higher bandwith than
>with the old cards etc. But now it doesnt hang the server on large files
>
>
>If you found a different solution let me know
>
>thanks
>dids
>
>


--
To unsubscribe send e-mail to suse-linux-e-unsubscribe@xxxxxxxx
For additional commands send e-mail to suse-linux-e-help@xxxxxxxx
Also check the FAQ at http://www.suse.com/Support/Doku/FAQ/


< Previous Next >