Mailinglist Archive: opensuse-buildservice (144 mails)

< Previous Next >
Re: [opensuse-buildservice] Issue with revision in git services
Am Mittwoch, den 25.09.2019, 18:02 +0200 schrieb Dominig ar Foll (Intel
Open Source):
Hello,

I try to extract a given review from gerrit with a service file and I
get an error that I do not understand
My _service points to a pending review.
- If I run the service locally with "osc service localrun" it works.
- if I run "git clone https://review.opendev.org/starlingx/fault
refs/changes/95/684395/5" I get the code

which code ? are the changes for the review really in there?

There is a line break in your command, which makes it hard to guess
what you really typed.

I would guess that you run

git fetch ...

and not clone

* if I run "osc service rr" I get an error "No such revision"

Could some one explains me what is wrong ?

obs-service-tar_scm does a

git clone <url>
cd <repo>
git checkout <revision>

you might need something like

git clone <url>
cd <repo>
git fetch <url> <refspec>
git checkout FETCH_HEAD



--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >