Mailinglist Archive: opensuse-buildservice (144 mails)

< Previous Next >
[opensuse-buildservice] wipebinaries doesn't work as expected
  • From: Hans-Peter Jansen <hpj@xxxxxxxxx>
  • Date: Tue, 03 Sep 2019 12:25:51 +0200
  • Message-id: <9863188.lRTfG1VLoE@xrated>
Hi,

I've build a package, that needs to link with problematic libs, therefor I've
added these dependencies with publishing disabled. For some reason, they were
published anyway, so I used my usual procedure:

osc wipebinaries --all prj pkg
disable publishing for pkg with web ui

Expected result: pkg gets rebuilt, but not published.
Achieved result: pkg gets rebuilt, but binaries are not wiped. IOW, they're
still published.

Next, I've tried to disable build for the whole project, and wiped everything:

osc wipebinaries --all prj

Now, *all* binaries vanished, but those, that I want to get rid of *remained*!
Next, I've tried all the other options as well:

osc wipebinaries --build-disabled home:frispete:Tumbleweed
osc wipebinaries --build-failed home:frispete:Tumbleweed
osc wipebinaries --unresolvable home:frispete:Tumbleweed
osc wipebinaries --broken home:frispete:Tumbleweed
osc wipebinaries --all home:frispete:Tumbleweed

but, after waiting for the project to be published, those packages still
exist:

https://download.opensuse.org/repositories/home:/frispete:/Tumbleweed/
openSUSE_Tumbleweed/x86_64/

Any idea, how I can get rid of these remaining packages? Call the Air Forces?

Thanks in advance.

Cheers,
Pete

System: Tumbleweed 20190829, osc 0.165.4


--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups