Mailinglist Archive: opensuse-buildservice (219 mails)

< Previous Next >
Re: [opensuse-buildservice] Re: Error at line 20 of cmake.spec
  • From: Michal Marek <mmarek@xxxxxxx>
  • Date: Fri, 01 Feb 2008 15:04:01 +0100
  • Message-id: <47A326D1.8070505@xxxxxxx>
G. Massera wrote:
I linked the cmake project contained in openSuse:10.3 ... and I found
and error at line 20 of cmake.spec that block compiling it on CentOS_5
and RHEL_5.
In details, this line give error on above platforms:
%if %suse_version > 1020
I think it should substitute with the more portable version documented
at
http://en.opensuse.org/Build_Service/cross_distribution_package_how_to#Detect_a_distribution_flavor_for_special_code

The BuildRequires field for CentOS_5 and RHEL_5 can be the same and
equal to:

BuildRequires: expat-devel curl-devel expat gcc-c++ libstdc++-devel
ncurses-devel

Do you have cmake package that builds on RHEL (and still builds on
openSUSE)? It would be great to build such tools in one place
(devel:tools:scm) for as many distributions as possible, to avoid having
to rebuild in other projects.

Michal
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
References