Mailinglist Archive: zypp-devel (23 mails)

< Previous Next >
[zypp-devel] unable to run zypper because of solv-file error
  • From: "Zhu, Peter J" <peter.j.zhu@xxxxxxxxx>
  • Date: Wed, 9 Sep 2009 15:13:28 +0800
  • Message-id: <9832F13BD22FB94A829F798DA4A8280501BFAD9AA2@xxxxxxxxxxxxxxxxxxxxxxxxxxxx>

I tried run zypper with yum repo in a moblin system but always failed. I used
zypper 1.2.2 and libzypp 6.11.4, very new.

At first stage, it always failed with "zypper refresh". After debugging, I
found it's because libzypp/zypp/media/proxyinfo/ doesn't
initialize the _enabled=false which got it always try to add '--http-proxy=' to
call augeas.

After fixing this, it can refresh cache successfully. But as I tried to "zypper
in cmake", it always complains that "Error reading solv-file:
/var/cache/zypp/solv/@System/solv". And I found the solv file is VOID(has zero

Any idea why this happens? Or Should I go back to an old version?

Look forward to your suggestions


To unsubscribe, e-mail: zypp-devel+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: zypp-devel+help@xxxxxxxxxxxx

< Previous Next >